Apache 2.0.x < 2.0.65 多种漏洞

medium Nessus 插件 ID 68914
全新!漏洞优先级评级 (VPR)

Tenable 测算每个漏洞的动态 VPR。VPR 将漏洞信息与威胁情报和机器学习算法相结合,预测哪些漏洞最有可能在攻击中被利用。了解详细信息: VPR 的定义及其与 CVSS 的区别。

VPR 得分: 7.9

简介

远程 Web 服务器会受到多个漏洞的影响。

描述

根据其标题,远程主机上运行的 Apache 2.0.x 版本低于 2.0.65。因此,它受到多个漏洞的影响:

- 存在于字节范围过滤器的漏洞,可能遭受拒绝服务。(CVE-2011-3192)

- “mod_proxy”中存在一个缺陷,即,其在反向代理配置中未正确与“RewriteRule”和“ProxyPassMatch”进行交互。(CVE-2011-3368)

- 存在一个权限升级漏洞,该漏洞与“mod_setenvif”模块的“ap_pregsub”函数中通过 .htaccess 文件导致的基于堆的缓冲区溢出有关。
(CVE-2011-3607)

- 记分板共享内存中存在一个本地安全绕过漏洞,可允许子进程造成父进程崩溃。
(CVE-2012-0031)

- 未指定自定义 ErrorDocument 时,状态代码 400 中存在一个缺陷,可泄露“httpOnly”Cookie。(CVE-2012-0053)

-“RewriteLog”函数中存在一个缺陷,即,该函数无法审查向日志文件写入的转义序列,这可导致执行任意命令。
(CVE-2013-1862)

请注意,远程 Web 服务器可能不会实际受到这些漏洞的影响。Nessus 不会试着确定受影响的模块是否在使用中,也不会对问题本身做测试。

解决方案

升级至 Apache 2.0.65 或更新版本。此为,还需确保没有使用受影响的模块。

另见

https://archive.apache.org/dist/httpd/CHANGES_2.0.65

http://www.nessus.org/u?366bbb5a

http://www.nessus.org/u?c309d2dd

插件详情

严重性: Medium

ID: 68914

文件名: apache_2_0_65.nasl

版本: 1.19

类型: remote

系列: Web Servers

发布时间: 2013/7/16

最近更新时间: 2019/11/27

依存关系: apache_http_version.nasl

风险信息

风险因素: Medium

VPR 得分: 7.9

CVSS 得分来源: CVE-2013-1862

CVSS v2.0

基本分数: 5.1

时间分数: 4.4

矢量: AV:N/AC:H/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS v3.0

基本分数: 9.1

时间分数: 8.7

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

可利用: true

易利用性: Exploits are available

补丁发布日期: 2013/7/10

漏洞发布日期: 2011/8/20

可利用的方式

Core Impact

参考资料信息

CVE: CVE-2011-3192, CVE-2011-3368, CVE-2011-3607, CVE-2012-0031, CVE-2012-0053, CVE-2013-1862

BID: 49303, 49957, 50494, 51407, 51706, 59826

EDB-ID: 17696, 17969, 18221, 18442