CentOS 5:php53 (CESA-2012:0547)

high Nessus 插件 ID 59058

简介

远程 CentOS 主机缺少一个或多个安全更新。

描述

更新后的 php53 程序包修复了一个安全问题,现在可用于 Red Hat Enterprise Linux 5。

Red Hat 安全响应团队已将此更新评级为具有严重安全影响。可从“参考”部分中的 CVE 链接获取通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

PHP 是一种嵌入了 HTML 的脚本语言,通常用于 Apache HTTP Server。

在以 CGI 模式运行时 php-cgi 可执行文件处理命令行参数的方式中发现了一个缺陷。远程攻击者可发送针对 PHP 脚本精心构建的请求,从而导致查询字符串被 php-cgi 作为命令行选项和参数进行解析。这可能造成脚本的源代码泄露或以 PHP 解释器的权限执行任意代码。(CVE-2012-1823)

Red Hat 意识到可以公开利用此问题,从而允许在受影响的 PHP CGI 配置中执行远程代码。
此缺陷不影响使用适用于 Apache httpd 的 PHP 模块处理 PHP 脚本这一默认配置。

所有 php53 用户都应升级这些更新后的程序包,其中包含用于解决此问题的向后移植的修补程序。安装更新后的程序包后,必须重新启动 httpd 后台程序才能使更新生效。

解决方案

更新受影响的 php53 程序包。

另见

http://www.nessus.org/u?ada2dd15

插件详情

严重性: High

ID: 59058

文件名: centos_RHSA-2012-0547.nasl

版本: 1.18

类型: local

代理: unix

发布时间: 2012/5/10

最近更新时间: 2022/3/28

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

风险信息

VPR

风险因素: High

分数: 8.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS 分数来源: CVE-2012-1823

漏洞信息

CPE: p-cpe:/a:centos:centos:php53, p-cpe:/a:centos:centos:php53-bcmath, p-cpe:/a:centos:centos:php53-cli, p-cpe:/a:centos:centos:php53-common, p-cpe:/a:centos:centos:php53-dba, p-cpe:/a:centos:centos:php53-devel, p-cpe:/a:centos:centos:php53-gd, p-cpe:/a:centos:centos:php53-imap, p-cpe:/a:centos:centos:php53-intl, p-cpe:/a:centos:centos:php53-ldap, p-cpe:/a:centos:centos:php53-mbstring, p-cpe:/a:centos:centos:php53-mysql, p-cpe:/a:centos:centos:php53-odbc, p-cpe:/a:centos:centos:php53-pdo, p-cpe:/a:centos:centos:php53-pgsql, p-cpe:/a:centos:centos:php53-process, p-cpe:/a:centos:centos:php53-pspell, p-cpe:/a:centos:centos:php53-snmp, p-cpe:/a:centos:centos:php53-soap, p-cpe:/a:centos:centos:php53-xml, p-cpe:/a:centos:centos:php53-xmlrpc, cpe:/o:centos:centos:5

必需的 KB 项: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2012/5/7

漏洞发布日期: 2012/5/11

CISA 已知利用日期: 2022/4/15

可利用的方式

CANVAS (CANVAS)

Core Impact

Metasploit (PHP CGI Argument Injection)

参考资料信息

CVE: CVE-2012-1823

BID: 53388

RHSA: 2012:0547