CentOS 4:ghostscript (CESA-2012:0096)

medium Nessus 插件 ID 57810
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 CentOS 主机缺少一个或多个安全更新。

描述

更新后的 ghostscript 程序包修复了两个安全问题,现在可用于 Red Hat Enterprise Linux 4。

Red Hat 安全响应团队已将此更新评级为具有中等安全影响。可从“参考”部分中的 CVE 链接获取针对每个漏洞的通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

Ghostscript 是一套提供 PostScript 解释器的软件、一套 C 程序(Ghostscript 库,用 PostScript 语言实现图形功能)和可移植文档格式 (PDF) 文件的解释器。

Ghostscript 默认在其库搜索路径中包含当前工作目录。如果用户在无“-P-”选项的情况下运行了受攻击者控制的包含特别构建的 PostScript 库文件的目录中的 Ghostscript,则可导致 Ghostscript 执行任意 PostScript 代码。通过此更新,Ghostscript 不再默认在当前工作目录中搜索库文件。
(CVE-2010-4820)

注意:针对 CVE-2010-4820 的补丁可能会破坏现有配置。要使用之前有漏洞的行为,请通过“-P”选项运行 Ghostscript(以始终首先搜索当前工作目录)。

在 Ghostscript 解释 PostScript Type 1 和 PostScript Type 2 字体文件的方式中发现一个缺陷。攻击者可以创建特别构建的 PostScript Type 1 或 PostScript Type 2 字体文件,解释该文件时可导致 Ghostscript 崩溃,或者可能执行任意代码。(CVE-2010-4054)

建议 Ghostscript 用户升级这些更新后的程序包,其中包含用于修正这些问题的向后移植的修补程序。

解决方案

更新受影响的 ghostscript 程序包。

另见

http://www.nessus.org/u?484e9bb6

插件详情

严重性: Medium

ID: 57810

文件名: centos_RHSA-2012-0096.nasl

版本: 1.12

类型: local

代理: unix

发布时间: 2012/2/3

最近更新时间: 2021/1/4

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2010-4820

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 4.4

时间分数: 3.8

矢量: AV:L/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:ND/RL:OF/RC:C

漏洞信息

CPE: p-cpe:/a:centos:centos:ghostscript, p-cpe:/a:centos:centos:ghostscript-devel, p-cpe:/a:centos:centos:ghostscript-gtk, cpe:/o:centos:centos:4

必需的 KB 项: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2012/2/2

漏洞发布日期: 2010/10/23

参考资料信息

CVE: CVE-2010-4054, CVE-2010-4820

BID: 43932

RHSA: 2012:0096