CentOS 6:jasper (CESA-2011:1807)

medium Nessus 插件 ID 57378

简介

远程 CentOS 主机缺少一个或多个安全更新。

描述

更新后的 jasper 程序包修复了两个安全问题,现在可用于 Red Hat Enterprise Linux 6。

Red Hat 安全响应团队已将此更新评级为具有重要安全影响。可从“参考”部分中的 CVE 链接获取针对每个漏洞的通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

JasPer 是 JPEG 2000 图像压缩标准第 1 部分的实现。

在 JasPer 解码 JPEG 2000 压缩图像文件的方式中发现两种基于堆的缓冲区溢出缺陷。攻击者可以创建恶意 JPEG 2000 压缩图像文件,打开时将导致使用 JasPer(如 Nautilus)的应用程序崩溃,或者可能导致执行任意代码。(CVE-2011-4516、CVE-2011-4517)

Red Hat 在此感谢 CERT Coordination Center 的 Jonathan Foote 报告这些问题。

建议用户升级这些更新后的程序包,其中包含用于修正这些问题的向后移植的修补程序。必须重新启动使用 JasPer 库的所有应用程序(例如 Nautilus)才能使更新生效。

解决方案

更新受影响的 jasper 程序包。

另见

http://www.nessus.org/u?4d07c296

插件详情

严重性: Medium

ID: 57378

文件名: centos_RHSA-2011-1807.nasl

版本: 1.20

类型: local

代理: unix

发布时间: 2011/12/23

最近更新时间: 2021/1/4

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

风险信息

VPR

风险因素: High

分数: 8.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5.9

矢量: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

漏洞信息

CPE: p-cpe:/a:centos:centos:jasper, p-cpe:/a:centos:centos:jasper-devel, p-cpe:/a:centos:centos:jasper-libs, p-cpe:/a:centos:centos:jasper-utils, cpe:/o:centos:centos:6

必需的 KB 项: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2011/12/22

漏洞发布日期: 2011/12/14

参考资料信息

CVE: CVE-2011-4516, CVE-2011-4517

BID: 50992

RHSA: 2011:1807