Mandriva Linux 安全公告:subversion (MDVSA-2011:067)

medium Nessus 插件 ID 53309
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Mandriva Linux 主机缺少一个或多个安全更新。

描述

在 subversion 中发现并修正了一个漏洞:

低于 1.6.16 版的 Apache Subversion 随附的 Apache HTTP Server 中,mod_dav_svn 模块允许远程攻击者通过含有锁定标记的请求造成拒绝服务(空指针取消引用和后台程序崩溃)(CVE-2011-0715)。

此外,因为数个上游补丁和新功能,已针对 Corporate Server 4 和 Enterprise Server 5 将 subversion 升级到 1.6.16 版,serf 程序包也已升级到现在需要的 0.3.0 版。

自扩展维护计划起,提供适用于 2009.0 的程序包。请访问此链接以了解更多信息:http://store.mandriva.com/product_info.php?cPath=149products_id=490

更新后的程序包已升级为 1.6.16 版,此版本不易受到该问题的影响。

解决方案

更新受影响的程序包。

另见

http://svn.apache.org/repos/asf/subversion/tags/1.6.16/CHANGES

插件详情

严重性: Medium

ID: 53309

文件名: mandriva_MDVSA-2011-067.nasl

版本: 1.10

类型: local

发布时间: 2011/4/7

最近更新时间: 2021/1/6

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.7

矢量: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

时间矢量: CVSS2#E:ND/RL:OF/RC:C

漏洞信息

CPE: cpe:2.3:o:mandriva:linux:2009.0:*:*:*:*:*:*:*, cpe:2.3:o:mandriva:linux:2010.0:*:*:*:*:*:*:*, cpe:2.3:o:mandriva:linux:2010.1:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:apache-mod_dav_svn:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:apache-mod_dontdothat:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64serf-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64serf0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64svn-gnome-keyring0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64svn-kwallet0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64svn0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64svnjavahl1:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libserf-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libserf0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libsvn-gnome-keyring0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libsvn-kwallet0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libsvn0:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libsvnjavahl1:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:perl-svn:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:python-svn:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:ruby-svn:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:subversion:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:subversion-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:subversion-doc:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:subversion-server:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:subversion-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:svn-javahl:*:*:*:*:*:*:*

必需的 KB 项: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2011/4/6

参考资料信息

CVE: CVE-2011-0715

BID: 46734

MDVSA: 2011:067