OpenSSL < 0.9.8q / 1.0.0c 多种漏洞

high Nessus 插件 ID 51058
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

根据其标题,远程 Web 服务器运行的 OpenSSL 版本低于 0.9.8q 或 1.0.0c。此类版本可能受到多种漏洞的影响:- 可通过修改存储的会话缓存加密套件来将加密套件降级至较弱版本。- J-PAKE 实现中存在一个错误,可导致不知道共享密码的人获得成功验证。

解决方案

请升级到 OpenSSL 0.9.8q / 1.0.0c 或更高版本。

另见

https://www.openssl.org/news/secadv/20101202.txt

http://seb.dbzteam.org/crypto/jpake-session-key-retrieval.pdf

插件详情

严重性: High

ID: 51058

文件名: openssl_1_0_0c.nasl

版本: 1.12

类型: remote

系列: Web Servers

发布时间: 2010/12/7

最近更新时间: 2018/7/16

依存关系: http_version.nasl

配置: 启用偏执模式

风险信息

VPR

风险因素: Medium

分数: 5.8

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2010/12/2

漏洞发布日期: 2010/12/2

参考资料信息

CVE: CVE-2010-4180, CVE-2010-4252

BID: 45163, 45164

Secunia: 42473