Apache Tomcat 4.x < 4.1.39 Multiple Vulnerabilities

medium Nessus 插件 ID 46867

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

根据其自我报告的版本号,在远程主机上监听的 Apache Tomcat 4.x 实例版本低于 4.1.39。因此,它受到以下一个或多个漏洞的影响:

- 如果远程安装的 Apache Tomcat 配置为使用 SingleSignOn Valve,认证通过 HTTPS 发生时,JSESSIONIDSSO cookie 将不会设置“secure”属性。请求 HTTP 内容时,此问题会导致将 JSESSIONIDSSO cookie 发送到相同服务器。(CVE-2008-0128)

- 远程 Apache Tomcat 安装容易遭受跨站脚本攻击。未正确验证输入,远程攻击者可利用此漏洞,将任意脚本代码或 HTML 注入 HttpServletResponse.sendError 方法使用的消息参数。(CVE-2008-1232)

- 如果远程安装的 Apache Tomcat 包含使用 RequestDispatcher 对象的页面,则可以发起目录遍历攻击。攻击者可利用此漏洞,选择一个或多个输入参数并提供特定值,从而导致访问潜在敏感文件。(CVE-2008-2370)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级到 Apache Tomcat 4.1.39 版本或更高版本。

另见

http://tomcat.apache.org/security-4.html#Fixed_in_Apache_Tomcat_4.1.39

插件详情

严重性: Medium

ID: 46867

文件名: tomcat_4_1_39.nasl

版本: 1.24

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2010/6/11

最近更新时间: 2020/3/11

依存关系: apache_tomcat_nix_installed.nbin, tomcat_win_installed.nbin, tomcat_error_version.nasl

风险信息

CVSS 分数来源: CVE-2008-0128

VPR

风险因素: Medium

分数: 4.2

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.9

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

必需的 KB 项: installed_sw/Apache Tomcat

可利用: true

易利用性: Exploits are available

补丁发布日期: 2008/12/2

漏洞发布日期: 2008/1/23

参考资料信息

CVE: CVE-2008-1232, CVE-2008-2370, CVE-2008-0128

BID: 30496, 30494, 27365

CWE: 79, 16, 22

Secunia: 28552, 31379