PHP 5 < 5.2.7 多种漏洞

high Nessus 插件 ID 35043

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题栏,远程主机上安装的 PHP 版本低于 5.2.7。因此,该服务器受到多个漏洞的影响:

- 捆绑 PCRE 库中存在允许拒绝访问攻击的缓冲区溢出缺陷。
(CVE-2008-2371)

-“posix_access”、“chdir”和“ftok”等函数中存在多个目录遍历漏洞,远程攻击者可利用此漏洞,绕过“safe_mode”限制(CVE-2008-2665 和 CVE-2008-2666)。

- 处理长消息头时,由于使用过时的 API 调用,可能会触发“php_imap.c”中的缓冲区溢出缺陷。可利用此缺陷造成拒绝服务或执行任意代码。
(CVE-2008-2829)

-“ext/gd/gd.c”的“imageloadfont”函数中存在缓冲区溢出,当提供特别构建的字体时,可触发此漏洞。利用此漏洞,可造成拒绝服务或执行任意代码。(CVE-2008-3658)

- PHP 内部函数“memnstr”中存在缓冲区溢出缺陷,攻击者可使用“explode”函数的分隔符参数,进而利用此漏洞。利用此漏洞,可造成拒绝服务或执行任意代码。(CVE-2008-3659)

- PHP 用作 FastCGI 模块时,攻击者可通过请求文件扩展名前有多个点的文件,造成拒绝服务。
(CVE-2008-3660)

- mbstring 扩展中存在基于堆的缓冲区溢出缺陷,通过特别构建的、包含未在 Unicode 转换期间处理的 HTML 实体的字符串,可触发此漏洞。利用此漏洞,可执行任意代码。(CVE-2008-5557)

- PHP 用作 Apache 模块时,未正确初始化全局变量“page_uid”和“page_gid”,此漏洞可导致绕过安全限制,这是 SAPI“php_getuid”函数过载所致。(CVE-2008-5624)

- 通过“httpd.conf”中的“php_admin_flag”设置启用“safe_mode”时,PHP 不强制执行正确的限制。此问题允许攻击者通过在“.htaccess”中放置特别构建的“php_value”来写入任意文件。
(CVE-2008-5625)

- ZipArchive 扩展中的“ZipArchive: : extractTo”函数未能从文件名中过滤目录遍历序列。攻击者可利用此漏洞,写入任意文件。(CVE-2008-5658)

- 在有限的情况下,攻击者可在调用具有无效参数的“dba_replace”函数时造成文件截断。(CVE-2008-7068)

-“xmlrpc.c”文件内的“date_from_ISO8601”函数中存在缓冲区溢出错误,这是未正确验证用户提供的输入所致。
远程攻击者可利用此缺陷造成拒绝服务或执行任意代码。
(CVE-2014-8626)

解决方案

升级至 PHP 5.2.8 或更高版本。

请注意,已从分发中删除版本 5.2.7,因为该版本中的回归导致“magic_quotes_gpc”设置即使在设置为开启时也会保持为关闭状态。

另见

http://cxsecurity.com/issue/WLB-2008110041

http://cxsecurity.com/issue/WLB-2008110058

http://cxsecurity.com/issue/WLB-2008120011

https://seclists.org/fulldisclosure/2008/Jun/237

https://seclists.org/fulldisclosure/2008/Jun/238

https://www.openwall.com/lists/oss-security/2008/08/08/2

https://www.openwall.com/lists/oss-security/2008/08/13/8

https://seclists.org/fulldisclosure/2008/Nov/674

https://seclists.org/fulldisclosure/2008/Dec/90

https://bugs.php.net/bug.php?id=42862

https://bugs.php.net/bug.php?id=45151

https://bugs.php.net/bug.php?id=45722

http://www.php.net/releases/5_2_7.php

http://www.php.net/ChangeLog-5.php#5.2.7

插件详情

严重性: High

ID: 35043

文件名: php_5_2_7.nasl

版本: 1.32

类型: remote

系列: CGI abuses

发布时间: 2008/12/5

最近更新时间: 2022/4/11

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2008/12/4

漏洞发布日期: 2008/6/19

参考资料信息

CVE: CVE-2008-2371, CVE-2008-2665, CVE-2008-2666, CVE-2008-2829, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2008-5557, CVE-2008-5624, CVE-2008-5625, CVE-2008-5658, CVE-2008-7068, CVE-2014-8626

BID: 29796, 29797, 29829, 30087, 30649, 31612, 32383, 32625, 32688, 32948, 70928

CWE: 20, 22, 119, 264