3Proxy HTTP 代理构建的透明请求远程溢出

high Nessus 插件 ID 31094

简介

远程代理受到一个缓冲区溢出漏洞的影响。

描述

远程主机正在运行 3proxy,这是一个支持 Telnet、FTP、WWW 等多项协议的应用程序代理。

在 0.5.3h 之前的 3proxy 和 20070413 之前的 0.6b-devel 中检测到一个堆栈溢出漏洞。通过在 HTTP GET 请求中发送长主机标头,远程攻击者可造成缓冲区溢出并执行任意代码。

解决方案

升级到 3proxy 版 0.5.3h 或更高版本。

另见

https://3proxy.ru/0.5.3h/Changelog.txt

https://www.securityfocus.com/archive/1/archive/1/466650/100/100/threaded

插件详情

严重性: High

ID: 31094

文件名: 3proxy_logurl_overflow.nasl

版本: 1.11

类型: remote

系列: Firewalls

发布时间: 2008/2/14

最近更新时间: 2018/11/15

支持的传感器: Nessus

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

漏洞信息

可利用: true

易利用性: Exploits are available

漏洞发布日期: 2007/4/14

参考资料信息

CVE: CVE-2007-2031

BID: 23545