PHP < 4.4.1 / 5.0.6 多种漏洞

high Nessus 插件 ID 20111

简介

远程 Web 服务器使用的 PHP 版本受到多种缺陷的影响。

描述

根据其标题,远程主机上安装的 PHP 版本低于 4.4.1 或 5.0.6。此类版本无法防止覆盖“$GLOBALS”超全局变量,这是文件上传处理代码以及“extract()”和“import_request_variables()”函数中的漏洞所致。根据受影响逐级上 PHP 应用程序的性质,利用此问题可能会导致任何数量的攻击,包括任意代码执行。

此外,即使在配置中明确禁用了 PHP 的“register_globals”设置,这些版本也可使攻击者能够利用 PCRE 库某些版本中的整数溢出缺陷来启用该设置,并且发起涉及 PHP 的“phpinfo()”函数的跨站脚本攻击。

解决方案

升级到 PHP 4.4.1 / 5.0.6 或更新版本。

另见

http://www.hardened-php.net/advisory_182005.77.html

http://www.hardened-php.net/advisory_192005.78.html

http://www.hardened-php.net/advisory_202005.79.html

http://www.php.net/release_4_4_1.php

插件详情

严重性: High

ID: 20111

文件名: php_4_4_1.nasl

版本: 1.25

类型: remote

系列: CGI abuses

发布时间: 2005/11/1

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

漏洞发布日期: 2005/8/20

参考资料信息

CVE: CVE-2002-0229, CVE-2005-2491, CVE-2005-3388, CVE-2005-3389, CVE-2005-3390

BID: 14620, 15248, 15249, 15250

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990