Debian dsa-5620:libunbound-dev - 安全更新

high Nessus 插件 ID 190510

简介

远程 Debian 主机上缺少一个或多个与安全性相关的更新。

描述

远程 Debian 11/12 主机上安装的多个程序包受到 dsa-5620 公告中提及的多个漏洞影响。

- 远程攻击者可利用 DNS 协议的某些 DNSSEC 方面(在 RFC 4033、4034、4035、6840 和相关 RFC 中),通过一个或多个 DNSSEC 响应造成拒绝服务情形(CPU 消耗),也称为 KeyTrap 问题。其中一个问题是,当存在包含多条 DNSKEY 和 RRSIG 记录的区域时,协议规范意味着算法必须评估 DNSKEY 和 RRSIG 记录的所有组合。(CVE-2023-50387)

- 远程攻击者可利用 DNS 协议的最近封装体验证方面(在跳过 RFC 9276 指南时的 RFC 5155 中),通过随机子域攻击中的 DNSSEC 响应造成拒绝服务情形(SHA-1 计算的 CPU 消耗),也称为 NSEC3 问题。RFC 5155 规范意味着算法在某些情况下必须执行数千次的哈希函数迭代。(CVE-2023-50868)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级 libunbound-dev 程序包。

另见

https://packages.debian.org/source/bullseye/unbound

https://packages.debian.org/source/bookworm/unbound

https://security-tracker.debian.org/tracker/source-package/unbound

https://security-tracker.debian.org/tracker/CVE-2023-50387

https://security-tracker.debian.org/tracker/CVE-2023-50868

插件详情

严重性: High

ID: 190510

文件名: debian_DSA-5620.nasl

版本: 1.5

类型: local

代理: unix

发布时间: 2024/2/14

最近更新时间: 2024/2/21

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

风险信息

VPR

风险因素: Medium

分数: 5.1

CVSS v2

风险因素: High

基本分数: 7.8

时间分数: 5.8

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS 分数来源: CVE-2023-50387

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:python3-unbound, p-cpe:/a:debian:debian_linux:libunbound8, cpe:/o:debian:debian_linux:11.0, p-cpe:/a:debian:debian_linux:unbound-host, p-cpe:/a:debian:debian_linux:unbound-anchor, p-cpe:/a:debian:debian_linux:unbound, p-cpe:/a:debian:debian_linux:libunbound-dev, cpe:/o:debian:debian_linux:12.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2024/2/14

漏洞发布日期: 2024/2/13

参考资料信息

CVE: CVE-2023-50387, CVE-2023-50868