Ubuntu 16.04 LTS / 18.04 LTS:OpenSSL 漏洞 (USN-6632-1)

medium Nessus 插件 ID 190449

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 16.04 LTS/18.04 LTS 主机上安装的程序包受到 USN-6632-1 公告中提及的多个漏洞的影响。

- 问题摘要:生成过长的 X9.42 DH 密钥或检查过长的 X9.42 DH 密钥或参数时可能会非常缓慢。影响汇总:使用函数 DH_generate_key() 生成 X9.42 DH 密钥的应用程序可能会遇到长时间的延迟。同样,使用 DH_check_pub_key()、DH_check_pub_key_ex() 或 EVP_PKEY_public_check() 检查 X9.42 DH 密钥或 X9.42 DH 参数的应用程序可能会遇到长时间的延迟。如果从不受信任的来源获取正在检查的密钥或参数,这可能导致拒绝服务。虽然 DH_check() 会执行所有必要的检查(自 CVE-2023-3817 起),但 DH_check_pub_key() 并不进行任何此类检查,因此容易受到过大 P 和 Q 参数的影响。同样,虽然 DH_generate_key() 会对过大的 P 参数执行检查,但它不会检查过大的 Q 参数。调用 DH_generate_key() 或 DH_check_pub_key(),并提供从不受信任之来源获取的密钥或参数的应用程序可能容易遭受拒绝服务攻击。DH_generate_key() 和 DH_check_pub_key() 也会被许多其他 OpenSSL 函数调用。调用任何其他函数的应用程序也可能会受到类似影响。受此影响的其他函数有 DH_check_pub_key_ex()、EVP_PKEY_public_check() 和 EVP_PKEY_generate()。使用 -pubcheck 选项时的 OpenSSL pkey 命令行应用程序,以及 OpenSSL genpkey 命令行应用程序均容易受到攻击。
OpenSSL SSL/TLS 实现不受此问题影响。OpenSSL 3.0 和 3.1 FIPS 提供程序不受此问题影响。(CVE-2023-5678)

- 问题摘要:处理恶意格式化的 PKCS12 文件可能会导致 OpenSSL 崩溃,进而导致潜在的拒绝服务攻击,影响汇总:从不受信任来源加载 PKCS12 格式文件的应用程序可能会突然终止。PKCS12 格式的文件可能包含证书和密钥,并可能来自不受信任的来源。PKCS12 规范允许特定字段为空,但 OpenSSL 未正确检查这种情况。这可能会导致空指针取消引用,进而造成 OpenSSL 崩溃。如果应用程序使用 OpenSSL API 处理来源不受信任的 PKCS12 文件,则该应用程序将很容易受到此问题的影响。存在此漏洞的 OpenSSL API 包括:
PKCS12_parse()、PKCS12_unpack_p7data()、PKCS12_unpack_p7encdata()、PKCS12_unpack_authsafes() 和 PKCS12_newpass()。我们也修复了 SMIME_write_PKCS7() 中存在的类似问题。但是,由于此函数与写入数据有关,我们认为它不会对安全性造成重大影响。3.2、3.1 和 3.0 中的 FIPS 模块不受此问题影响。(CVE-2024-0727)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新受影响的程序包。

另见

https://ubuntu.com/security/notices/USN-6632-1

插件详情

严重性: Medium

ID: 190449

文件名: ubuntu_USN-6632-1.nasl

版本: 1.3

类型: local

代理: unix

发布时间: 2024/2/13

最近更新时间: 2024/4/11

支持的传感器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS 分数来源: CVE-2023-5678

CVSS v3

风险因素: Medium

基本分数: 5.5

时间分数: 4.8

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

CVSS 分数来源: CVE-2024-0727

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:16.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libssl-dev, p-cpe:/a:canonical:ubuntu_linux:libssl1.0.0, p-cpe:/a:canonical:ubuntu_linux:openssl, p-cpe:/a:canonical:ubuntu_linux:libssl1.1

必需的 KB 项: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

易利用性: No known exploits are available

补丁发布日期: 2024/2/13

漏洞发布日期: 2023/11/6

参考资料信息

CVE: CVE-2023-5678, CVE-2024-0727

IAVA: 2024-A-0121-S

USN: 6632-1