Debian dsa-5616:ruby-sanitize - 安全更新

medium Nessus 插件 ID 190002

简介

远程 Debian 主机缺少与安全相关的更新。

描述

远程 Debian 11/12 主机上安装的程序包受到 dsa-5616 公告中提及的一个漏洞影响。

- Sanitize 是一种基于白名单的 HTML 和 CSS 审查器。通过使用精心构建的输入,当 Sanitize 被配置为使用内置宽松配置或使用允许“style”元素及一个或多个 CSS at-rule 的自定义配置时,攻击者可能可以通过 3.0.0 至 6.0.2 版本之间的 Sanitize 来偷偷入侵任意 HTML 和 CSS。如果恶意 HTML 和 CSS 在浏览器中经过渲染,这可能会导致发生跨站脚本漏洞或其他意外行为。Sanitize 6.0.2 在“style”元素内容中执行额外的 CSS 转义,从而修复了此问题。无法升级的用户可以通过使用不允许“style”元素的 Sanitize 配置、使用不允许 CSS at-rule 的 Sanitize 配置或将“style”元素内容中的字符序列“</”手动转义为“<\/”来防止出现此问题。(CVE-2023-36823)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级 ruby-sanitize 程序包。

另见

http://www.nessus.org/u?e8efe62e

https://security-tracker.debian.org/tracker/CVE-2023-36823

https://packages.debian.org/source/bookworm/ruby-sanitize

https://packages.debian.org/source/bullseye/ruby-sanitize

插件详情

严重性: Medium

ID: 190002

文件名: debian_DSA-5616.nasl

版本: 1.0

类型: local

代理: unix

发布时间: 2024/2/6

最近更新时间: 2024/2/6

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

风险信息

VPR

风险因素: Low

分数: 3.0

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 4.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS 分数来源: CVE-2023-36823

CVSS v3

风险因素: Medium

基本分数: 6.1

时间分数: 5.3

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:ruby-sanitize, cpe:/o:debian:debian_linux:11.0, cpe:/o:debian:debian_linux:12.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2024/2/5

漏洞发布日期: 2023/7/6

参考资料信息

CVE: CVE-2023-36823