Debian dla-3719: php-seclib - 安全更新

medium Nessus 插件 ID 189491

简介

远程 Debian 主机缺少与安全相关的更新。

描述

远程 Debian 10 主机上安装的程序包受到 dla-3719 公告中提及的一个漏洞影响。

- 具有某些 OpenSSH 扩展的 SSH 传输协议(在 9.6 之前的 OpenSSH 和其他产品中发现)允许远程攻击者绕过完整性检查,从而省略某些数据包(从扩展协商消息中),并且客户端和服务器可能因此而结束某些安全功能已被降级或禁用的连接,也称为 Terrapin 攻击。发生这种情况是因为这些扩展实现的 SSH 二进制数据包协议 (BPP) 错误地处理了握手阶段并错误地处理了序列号的使用。例如,有一种针对 SSH 使用 ChaCha20-Poly1305(以及使用 Encrypt-then-MAC 的 CBC)的有效攻击。绕过发生在 [email protected] 和(如果使用 CBC)[email protected] MAC 算法中。这也会影响 3.1.0-SNAPSHOT 之前的 Maverick Synergy Java SSH API、2022.83 及之前的 Dropbear、Erlang/OTP 中 5.1.1 之前的 Ssh、0.80 之前的 PuTTY、2.14.2 之前的 AsyncSSH、0.17.0 之前的 golang.org/x/crypto 、0.10.6 之前的 libssh、1.11.0 及之前的 libssh2、3.4.6 之前的 Thorn Tech SFTP Gateway、5.1 之前的 Tera Term、3.4.0 之前的 Paramiko、0.2.15 之前的 jsch、2.5.6 之前的 SFTPGo、23.09.1 及之前的 Netgate pfSense Plus、2.7.2 及之前的 Netgate pfSense CE、18.2.0 及之前的 HPN-SSH、1.3.8b 之前(及 1.3.9rc2 之前)的 ProFTPD、2.3.4 之前的 ORYX CycloneSSH、Build 0144 之前的 NetSarang XShell 7、10.6.0 之前的 CrushFTP、2.2.22 之前的 ConnectBot SSH 库、2.11.0 及之前的 Apache MINA sshd、0.37.0 及之前的 sshj、20230101 及之前的 TinySSH、trilead-ssh2 6401、LANCOM LCOS 及 LANconfig、3.66.4 之前的 FileZilla、11.8 之前的 Nova、14.4 之前的 PKIX-SSH、9.4.3 之前的 SecureCRT、5.10.4 之前的 Transmit5、9.5.0.0p1-Beta 之前的 Win32-OpenSSH、6.2.2 之前的 WinSCP、9.32 之前的 Bitvise SSH Server、9.33 之前的 Bitvise SSH Client、0.76.1.13 及之前的 KiTTY、适用于 Ruby 的 net-ssh gem 7.2.0、 1.15.0 之前的 mscdex ssh2 模块(适用于 Node.js)、0.35.1 之前的 thrussh 库(适用于 Rust)以及 0.40.2 之前的 Russh crate(适用于 Rust)。(CVE-2023-48795)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级 php-seclib 程序包。

另见

https://security-tracker.debian.org/tracker/source-package/phpseclib

https://security-tracker.debian.org/tracker/CVE-2023-48795

https://packages.debian.org/source/buster/phpseclib

插件详情

严重性: Medium

ID: 189491

文件名: debian_DLA-3719.nasl

版本: 1.0

类型: local

代理: unix

发布时间: 2024/1/25

最近更新时间: 2024/1/25

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 5.4

时间分数: 4.2

矢量: CVSS2#AV:N/AC:H/Au:N/C:N/I:C/A:N

CVSS 分数来源: CVE-2023-48795

CVSS v3

风险因素: Medium

基本分数: 5.9

时间分数: 5.3

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:php-seclib, cpe:/o:debian:debian_linux:10.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2024/1/25

漏洞发布日期: 2023/12/18

参考资料信息

CVE: CVE-2023-48795