Ubuntu 16.04 ESM / 18.04 ESM / 20.04 LTS / 22.04 LTS / 23.04 / 23.10 : OpenJDK 8 漏洞 (USN-6528-1)

medium Nessus 插件 ID 186448

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 16.04 ESM/18.04 ESM/20.04 LTS/22.04 LTS/23.10 主机上安装的多个程序包受到 USN-6528-1 公告中提及的多个漏洞影响。

- 在 Oracle JDK (HotSpot VM) 11、17 及 OpenJDK (HotSpot VM) 8、11、17 的函数 ciMethodBlocks: : make_block_at 中发现问题,允许攻击者造成拒绝服务。(CVE-2022-40433)

- Oracle Java SE、Oracle GraalVM for JDK、Oracle Java SE 的 Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Hotspot)。受影响的支持版本有 Oracle Java SE:8u381-perf、17.0.8、21;Oracle GraalVM for JDK:17.0.8、21;Oracle GraalVM Enterprise Edition:21.3.7 和 22.3.3。
攻击此漏洞的难度较大,通过多种协议访问网络的未经身份验证的攻击者可以利用此漏洞破坏 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。
若攻击成功,攻击者可在未经授权的情况下更新、插入或删除 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 的部分可访问数据。注意:
攻击者也可通过使用指定组件中的 API 来利用此漏洞,例如通过向 API 提供数据的 Web 服务。此漏洞也适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。(CVE-2023-22025)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:CORBA)。受影响的支持版本有 Oracle Java SE:8u381、8u381-perf;Oracle GraalVM Enterprise Edition:20.3.11 和 21.3.7。利用该漏洞的难度较低,未经身份验证的攻击者可通过 CORBA 进行网络访问,从而破坏 Oracle Java SE 和 Oracle GraalVM Enterprise Edition。
成功攻击此漏洞可能导致在未经授权的情况下,即可访问并更新、插入或删除 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 的部分可访问数据。注意:此漏洞只能通过向指定组件中的 API 提供数据而遭到利用,不使用不可信的 Java Web Start 应用程序或不可信的 Java 小程序,例如通过 Web 服务。(CVE-2023-22067)

- Oracle Java SE、Oracle GraalVM for JDK、Oracle Java SE 的 Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:JSSE)。受影响的支持版本有 Oracle Java SE:8u381、8u381-perf、11.0.20、17.0.8、21;Oracle GraalVM for JDK:17.0.8、21;Oracle GraalVM Enterprise Edition:
20.3.11、21.3.7 和 22.3.3。可轻松利用的漏洞允许未经身份验证的攻击者通过 HTTPS 进行网络访问,从而破坏 Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。
如果攻击成功,攻击者可在未经授权的情况下造成 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 部分拒绝服务(部分 DOS)。注意:
此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞不适用于仅加载并运行可信代码(如管理员安装的代码)的 Java 部署,此部署通常存在于服务器上。(CVE-2023-22081)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的程序包。

另见

https://ubuntu.com/security/notices/USN-6528-1

插件详情

严重性: Medium

ID: 186448

文件名: ubuntu_USN-6528-1.nasl

版本: 1.1

类型: local

代理: unix

发布时间: 2023/11/29

最近更新时间: 2023/11/30

支持的传感器: Frictionless Assessment Azure, Nessus Agent, Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus

风险信息

VPR

风险因素: Low

分数: 2.2

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.9

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS 分数来源: CVE-2023-22067

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:esm, cpe:/o:canonical:ubuntu_linux:18.04:-:esm, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, cpe:/o:canonical:ubuntu_linux:23.04, cpe:/o:canonical:ubuntu_linux:23.10, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-demo, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jdk, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jdk-headless, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre-headless, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre-jamvm, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre-zero, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-source

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2023/11/29

漏洞发布日期: 2023/8/22

参考资料信息

CVE: CVE-2022-40433, CVE-2023-22025, CVE-2023-22067, CVE-2023-22081

USN: 6528-1