PHP 4.x < 4.3.0 ZendEngine 整数溢出

high Nessus 插件 ID 17796

简介

可以在远程服务器上运行任意代码。

描述

远程服务器正在运行早于 4.3.0 的 PHP 4.x 版本。因此,有报告称其在数组创建中存在整数溢出,可由传递给“unserialize()”函数的用户输入触发。

成功利用此漏洞可允许攻击者在此主机上执行任意代码。

解决方案

请升级到 PHP 4.3.0 或更高版本。

另见

http://www.hardened-php.net/advisory_092006.133.html

插件详情

严重性: High

ID: 17796

文件名: php_4_3_0_zendengine.nasl

版本: 1.7

类型: remote

系列: CGI abuses

发布时间: 2012/1/11

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

漏洞发布日期: 2006/10/5

参考资料信息

CVE: CVE-2006-4812

BID: 20349

CWE: 94