OpenSSL < 0.9.8p / 1.0.0b 缓冲区溢出

high Nessus 插件 ID 17766
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程服务器受到缓冲区溢出漏洞的影响。

描述

根据其标题,远程服务器正在运行早于 0.9.8p / 1.0.0b 的 OpenSSL 版本。

如果 TLS 服务器为多线程并使用 SSL 缓存,则远程攻击者可触发缓冲区溢出并使服务器崩溃或运行任意代码。

解决方案

升级到 OpenSSL 0.9.8p / 1.0.0b 或更高版本。

另见

https://www.openssl.org/news/secadv/20101116.txt

插件详情

严重性: High

ID: 17766

文件名: openssl_0_9_8p_1_0_0b.nasl

版本: 1.10

类型: remote

系列: Web Servers

发布时间: 2012/1/4

最近更新时间: 2018/7/16

依存关系: openssl_version.nasl

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.6

时间分数: 5.6

矢量: AV:N/AC:H/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: openssl/port

易利用性: No known exploits are available

补丁发布日期: 2010/11/16

漏洞发布日期: 2010/11/16

参考资料信息

CVE: CVE-2010-3864

BID: 44884