Apache Tomcat 4.x < 4.1.36 多种漏洞

medium Nessus 插件 ID 17726

简介

远程 Apache Tomcat 服务器受到多种漏洞的影响。

描述

根据其自我报告的版本号,在远程主机上监听的 Apache Tomcat 4.x 实例版本低于 4.1.36。因此,它受到以下漏洞的影响:

- 包含多个“content-length”头的请求不会因无效而遭到拒绝。此错误可导致 Web 缓存毒化、跨站脚本攻击和信息泄露。(CVE-2005-2090)

- 存在输入审查错误,可导致通过目录遍历泄露敏感信息。将服务器配置为使用“代理”模式时会暴露此漏洞。
(CVE-2007-0450)

- 未正确验证“Accept-Language”头,可导致跨站脚本攻击。
(CVE-2007-1358)

请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

更新到 Apache Tomcat 版本 4.1.36 或更高版本。

另见

http://tomcat.apache.org/security-4.html#Fixed_in_Apache_Tomcat_4.1.36

插件详情

严重性: Medium

ID: 17726

文件名: tomcat_4_1_36.nasl

版本: 1.15

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2011/11/18

最近更新时间: 2022/4/11

配置: 启用彻底检查

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Low

分数: 2.2

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.9

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:POC/RL:OF/RC:C

CVSS 分数来源: CVE-2005-2090

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:tomcat

必需的 KB 项: installed_sw/Apache Tomcat

可利用: true

易利用性: Exploits are available

补丁发布日期: 2007/4/7

漏洞发布日期: 2005/6/6

参考资料信息

CVE: CVE-2005-2090, CVE-2007-0450, CVE-2007-1358

BID: 13873, 22960, 24524

CWE: 22, 79