Debian DSA-5351-1:webkit2gtk - 安全更新

high Nessus 插件 ID 171614

简介

远程 Debian 主机缺少与安全相关的更新。

描述

远程 Debian 11 主机上安装的多个程序包受到 dsa-5351 公告中提及的一个漏洞影响。

- 已通过改进的检查处理解决类型混淆问题。 (CVE-2023-23529)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级 webkit2gtk 程序包。

对于稳定发行版本 (bullseye),已在 2.38.5-1~deb11u1 版本中解决此问题。

另见

https://security-tracker.debian.org/tracker/source-package/webkit2gtk

https://www.debian.org/security/2023/dsa-5351

https://security-tracker.debian.org/tracker/CVE-2023-23529

https://packages.debian.org/source/bullseye/webkit2gtk

插件详情

严重性: High

ID: 171614

文件名: debian_DSA-5351.nasl

版本: 1.1

类型: local

代理: unix

发布时间: 2023/2/17

最近更新时间: 2023/3/9

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 8.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2023-23529

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 8.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:H/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-4.0, p-cpe:/a:debian:debian_linux:gir1.2-webkit2-4.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-18, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-bin, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-dev, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-37, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-dev, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-doc, p-cpe:/a:debian:debian_linux:webkit2gtk-driver, cpe:/o:debian:debian_linux:11.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2023/2/17

漏洞发布日期: 2023/2/16

CISA 已知可遭利用的漏洞到期日期: 2023/3/7

参考资料信息

CVE: CVE-2023-23529