Debian DLA-3313-1:wireshark - LTS 安全更新

high Nessus 插件 ID 171394

简介

远程 Debian 主机上缺少一个或多个与安全性相关的更新。

描述

远程 Debian 10 主机上安装的程序包受到 dla-3313 公告中提及的多个漏洞影响。

- Wireshark 4.0.0 至 4.0.1 版本以及 3.6.0 至 3.6.9 版本的 BPv6、OpenFlow 和 Kafka 协议分析器中存在无限循环漏洞,攻击者可利用此漏洞通过数据包注入或特制的捕获文件造成拒绝服务 (CVE-2022-4345)

- Wireshark 4.0.0 至 4.0.2 版本和 3.6.0 至 3.6.10 版本的多个分析器中存在过度循环漏洞,攻击者可利用这些漏洞通过注入数据包或构建的捕获文件造成拒绝服务 (CVE-2023-0411)

- Wireshark 4.0.0 至 4.0.2 和 3.6.0 至 3.6.10 版本中存在 TIPC 分析器崩溃漏洞,攻击者可通过注入数据包或构建捕获文件造成拒绝服务 (CVE-2023-0412)

- Wireshark 4.0.0 至 4.0.2 和 3.6.0 至 3.6.10 版本中存在分析器引擎缺陷,攻击者可利用此漏洞通过注入数据包或构建的捕获文件造成拒绝服务 (CVE-2023-0413)

- Wireshark 4.0.0 至 4.0.2 和 3.6.0 至 3.6.10 版本中存在 iSCSI 分析器崩溃漏洞,攻击者可利用此漏洞通过注入数据包或构建的捕获文件造成拒绝服务 (CVE-2023-0415)

- Wireshark 4.0.0 至 4.0.2 和 3.6.0 至 3.6.10 版本中的 NFS 分析器中存在内存泄漏问题,攻击者可利用此漏洞,通过数据包注入或构建的捕获文件造成拒绝服务 (CVE-2023-0417)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级 wireshark 程序包。

对于 Debian 10 buster,已在 2.6.20-0+deb10u5 版本中修复这些问题。

另见

https://security-tracker.debian.org/tracker/source-package/wireshark

https://www.debian.org/lts/security/2023/dla-3313

https://security-tracker.debian.org/tracker/CVE-2022-4345

https://security-tracker.debian.org/tracker/CVE-2023-0411

https://security-tracker.debian.org/tracker/CVE-2023-0412

https://security-tracker.debian.org/tracker/CVE-2023-0413

https://security-tracker.debian.org/tracker/CVE-2023-0415

https://security-tracker.debian.org/tracker/CVE-2023-0417

https://packages.debian.org/source/buster/wireshark

插件详情

严重性: High

ID: 171394

文件名: debian_DLA-3313.nasl

版本: 1.5

类型: local

代理: unix

发布时间: 2023/2/13

最近更新时间: 2023/9/4

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 4.2

CVSS v2

风险因素: High

基本分数: 8.5

时间分数: 6.3

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

CVSS 分数来源: CVE-2023-0412

CVSS v3

风险因素: High

基本分数: 7.1

时间分数: 6.2

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:libwireshark-data, p-cpe:/a:debian:debian_linux:libwireshark-dev, p-cpe:/a:debian:debian_linux:libwireshark11, p-cpe:/a:debian:debian_linux:libwiretap-dev, p-cpe:/a:debian:debian_linux:libwiretap8, p-cpe:/a:debian:debian_linux:libwscodecs2, p-cpe:/a:debian:debian_linux:libwsutil-dev, p-cpe:/a:debian:debian_linux:libwsutil9, p-cpe:/a:debian:debian_linux:tshark, p-cpe:/a:debian:debian_linux:wireshark, p-cpe:/a:debian:debian_linux:wireshark-common, p-cpe:/a:debian:debian_linux:wireshark-dev, p-cpe:/a:debian:debian_linux:wireshark-doc, p-cpe:/a:debian:debian_linux:wireshark-gtk, p-cpe:/a:debian:debian_linux:wireshark-qt, cpe:/o:debian:debian_linux:10.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2023/2/13

漏洞发布日期: 2022/12/7

参考资料信息

CVE: CVE-2022-4345, CVE-2023-0411, CVE-2023-0412, CVE-2023-0413, CVE-2023-0415, CVE-2023-0417

IAVB: 2023-B-0004-S, 2023-B-0008-S