Oracle Linux 8:varnish: 6 (ELSA-2022-8649)

high Nessus 插件 ID 168226

简介

远程 Oracle Linux 主机缺少安全更新。

描述

远程 Oracle Linux 8 主机上安装的程序包受到 ELSA-2022-8649 公告中提及的漏洞的影响。

- 在 5.x 版、6.0.11 之前的 6.x 版、7.1.2 之前的 7.x 版、7.2.1 之前的 7.2.x 版的 Varnish Cache 中发现了一个 HTTP 请求伪造问题。攻击者可能通过在 HTTP/1 请求行上下文中无效的 HTTP/2 伪标头引入字符,从而导致 Varnish 服务器向后端生成无效的 HTTP/1 请求。反过来,攻击者可借机利用 Varnish 服务器后面的服务器中的漏洞。注意: 6.0.x LTS 系列(低于 6.0.11 版)受到影响。(CVE-2022-45060)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的程序包。

另见

https://linux.oracle.com/errata/ELSA-2022-8649.html

插件详情

严重性: High

ID: 168226

文件名: oraclelinux_ELSA-2022-8649.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2022/11/28

最近更新时间: 2022/11/28

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: High

基本分数: 7.8

时间分数: 5.8

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS 分数来源: CVE-2022-45060

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:varnish, p-cpe:/a:oracle:linux:varnish-devel, p-cpe:/a:oracle:linux:varnish-docs, p-cpe:/a:oracle:linux:varnish-modules

必需的 KB 项: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

易利用性: No known exploits are available

补丁发布日期: 2022/11/28

漏洞发布日期: 2022/11/9

参考资料信息

CVE: CVE-2022-45060