Oracle Linux 9:wavpack (ELSA-2022-8139)

medium Nessus 插件 ID 168118

简介

远程 Oracle Linux 主机缺少安全更新。

描述

远程 Oracle Linux 9 主机上安装的多个程序包受到 ELSA-2022-8139 公告中提及的一个漏洞影响。

- 在 Wavpack 5.4.0 中,处理 *.WAV 文件时发现越界读取漏洞。此问题在 src/pack_utils.c 文件的 WavpackPackSamples 函数中触发,受感染的变量 cnt 过大,造成 sptr 指针读取数据时超出堆边界。(CVE-2021-44269)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的 wavpack 和/或 wavpack-devel 程序包。

另见

https://linux.oracle.com/errata/ELSA-2022-8139.html

插件详情

严重性: Medium

ID: 168118

文件名: oraclelinux_ELSA-2022-8139.nasl

版本: 1.3

类型: local

代理: unix

发布时间: 2022/11/22

最近更新时间: 2023/10/2

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.4

矢量: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS 分数来源: CVE-2021-44269

CVSS v3

风险因素: Medium

基本分数: 5.5

时间分数: 5

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/o:oracle:linux:9, p-cpe:/a:oracle:linux:wavpack, p-cpe:/a:oracle:linux:wavpack-devel

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

可利用: true

易利用性: Exploits are available

补丁发布日期: 2022/11/22

漏洞发布日期: 2022/3/10

参考资料信息

CVE: CVE-2021-44269