GLSA-202211-08:sudo:基于堆的缓冲区过度读取

high Nessus 插件 ID 168041

语言:

描述

远程主机受到 GLSA-202211-08 中所述漏洞的影响(sudo:基于堆的缓冲区过度读取)

- 在具有 crypt() 密码后端的 Sudo 1.8.0 至 1.9.12 版中,plugins/sudoers/auth/passwd.c 存在数组越界错误,可导致基于堆的缓冲区过度读取。具有 Sudo 访问权限的任意本地用户可通过输入不超过 7 个字符的密码来触发此问题。此问题造成的影响可能因系统库、编译器和处理器架构而异。(CVE-2022-43995)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

所有 sudo 用户都应升级到最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=app-admin/sudo-1.9.12-r1

另见

https://security.gentoo.org/glsa/202211-08

https://bugs.gentoo.org/show_bug.cgi?id=879209

插件详情

严重性: High

ID: 168041

文件名: gentoo_GLSA-202211-08.nasl

版本: 1.2

类型: local

发布时间: 2022/11/22

最近更新时间: 2022/11/22

风险信息

VPR

风险因素: Medium

分数: 6

CVSS v2

风险因素: Medium

基本分数: 6.2

时间分数: 4.6

矢量: AV:L/AC:L/Au:S/C:C/I:N/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-43995

CVSS v3

风险因素: High

基本分数: 7.1

时间分数: 6.2

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:gentoo:linux:sudo, cpe:/o:gentoo:linux

必需的 KB 项: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

易利用性: No known exploits are available

补丁发布日期: 2022/11/22

漏洞发布日期: 2022/11/2

参考资料信息

CVE: CVE-2022-43995