OpenSSL 3.0.0 < 3.0.7 多种漏洞

high Nessus 插件 ID 166773

简介

远程服务受到多种漏洞影响。

描述

远程主机上安装的 OpenSSL 版本低于 3.0.7。因此,它受到 3.0.7 公告中提及的多个漏洞影响。

- 缓冲区溢出可在 X.509 证书验证中触发,在名称限制检查中更是如此。请注意,这会在证书链签名验证之后发生,并且需要 CA 签署恶意证书,或者要求应用程序在未能构建到受信任颁发者的路径的情况下继续证书验证。攻击者可特制证书中的恶意电子邮件地址,以在堆栈上溢出包含“.”字符(十进制 46)的任意数量的字节。此缓冲区溢出可能会导致崩溃(造成拒绝服务)。在 TLS 客户端中,这可通过连接到恶意服务器来触发。在 TLS 服务器中,如果服务器请求客户端认证并连接了恶意客户端,就会触发此问题。(CVE-2022-3786)

- 缓冲区溢出可在 X.509 证书验证中触发,在名称限制检查中更是如此。请注意,这会在证书链签名验证之后发生,并且需要 CA 签署恶意证书,或者要求应用程序在未能构建到受信任颁发者的路径的情况下继续证书验证。攻击者可以构建恶意电子邮件地址,使堆栈上四个由攻击者控制的字节溢出。此缓冲区溢出可能会导致崩溃(造成拒绝服务)或远程代码执行。许多平台实现了堆栈溢出保护,可降低远程代码执行的风险。可根据任何给定平台/编译器的堆栈布局进一步缓解此风险。 CVE-2022-3602 的预先公告将此问题描述为“危急”。基于上述一些缓解因素的进一步分析可将此问题降级为“高危”。仍建议用户尽快升级到新版本。在 TLS 客户端中,这可通过连接到恶意服务器来触发。
在 TLS 服务器中,如果服务器请求客户端认证并连接了恶意客户端,就会触发此问题。(CVE-2022-3602)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级到 OpenSSL 版本 3.0.7 或更高版本。

另见

https://www.openssl.org/news/secadv/20221101.txt

http://www.nessus.org/u?a438010d

插件详情

严重性: High

ID: 166773

文件名: openssl_3_0_7.nasl

版本: 1.8

类型: remote

系列: Web Servers

发布时间: 2022/11/1

最近更新时间: 2022/12/15

风险信息

VPR

风险因素: High

分数: 7.1

CVSS v2

风险因素: High

基本分数: 7.8

时间分数: 5.8

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-3786

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: openssl/port

易利用性: No known exploits are available

补丁发布日期: 2022/11/1

漏洞发布日期: 2022/11/1

参考资料信息

CVE: CVE-2022-3602, CVE-2022-3786

IAVA: 2022-A-0452-S

CEA-ID: CEA-2022-0036