GLSA-202210-32 : hiredis、hiredis-py:多个漏洞

high Nessus 插件 ID 166737

语言:

描述

远程主机受到 GLSA-202210-32 中所述漏洞的影响(hiredis、hiredis-py:多个漏洞)

- Hiredis 是用于 Redis 数据库的极简 C 客户端库。在受影响的版本中,如果提供恶意构建或损坏的“RESP”“多批量”协议数据,Hiredis 将会容易受到整数溢出漏洞的影响。解析“multi-bulk”(类数组)回复时,hiredis 无法检查是否可以“SIZE_MAX”表示“count * sizeof(redisReply*)”。如果不能,并且“calloc()”调用本身不执行此检查,则这会导致短分配和后续缓冲区溢出。无法更新的 hiredis 用户可将 [maxelements](https://github.com/redis/hiredis#reader-max-array-elements) 上下文选项设置为足够小的值,以保证不会发生溢出。(CVE-2021-32765)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

所有 hiredis 用户应升级到最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-libs/hiredis-1.0.1 所有 hiredis-py 用户应升级到最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-python/hiredis-2.0.0

另见

https://security.gentoo.org/glsa/202210-32

https://bugs.gentoo.org/show_bug.cgi?id=816318

https://bugs.gentoo.org/show_bug.cgi?id=873079

插件详情

严重性: High

ID: 166737

文件名: gentoo_GLSA-202210-32.nasl

版本: 1.2

类型: local

发布时间: 2022/10/31

最近更新时间: 2022/10/31

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.5

时间分数: 4.8

矢量: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-32765

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:hiredis:*:*:*:*:*:*:*

必需的 KB 项: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

易利用性: No known exploits are available

补丁发布日期: 2022/10/31

漏洞发布日期: 2021/10/4

参考资料信息

CVE: CVE-2021-32765