Atlassian Confluence < 7.4.17 / 7.5.x < 7.13.7 / 7.14.x < 7.14.3 / 7.15.x < 7.15.2 / 7.16.x < 7.16.4 / 7.17.x < 7.17.4 XSS (CONFSERVER-79476)

critical Nessus 插件 ID 163307

简介

远程 Atlassian Confluence 主机缺少安全更新。

描述

远程主机上安装的 Atlassian Confluence 版本低于 < 7.4.17 / 7.5.x < 7.13.7 / 7.14.x < 7.14.3 / 7.15.x < 7.15.2 / 7.16.x < 7.16.4 / 7.17.x < 7.17.4。因此,它受到 CONFSERVER-79476 公告中提及的漏洞影响。

- 已修复 Confluence Server 和 Data Center 中的多个 Servlet 过滤器漏洞,这些漏洞也会影响其他 Atlassian 产品。如需了解更多信息,请参阅 Atlassian 安全公告 |https://confluence.atlassian.com/security/multiple-products-security-advisory-cve-2022-26136-cve-2022-26137-1141493031.html]. h3。任意 Servlet 过滤器绕过 (CVE-2022-26136) 未经身份验证的远程攻击者可绕过第一方和第三方应用程序使用的 Servlet 过滤器,其影响取决于每个应用程序使用的过滤器及其使用方式。Atlassian 已发布可修复此漏洞根本原因的更新,但并未详尽列出此漏洞的所有潜在后果。仅确认了以下攻击:{*}绕过身份验证{*}。通过发送特别构建的 HTTP 请求,可绕过第三方应用程序用于强制身份验证的自定义 Servlet 过滤器。未经身份验证的远程攻击者可利用此问题绕过第三方应用程序使用的身份验证。请注意,Atlassian 已确认可能受到此攻击,但尚未确定所有受影响应用程序的列表。 {*}跨站脚本 (XSS){*}。通过发送特别构建的 HTTP 请求,可绕过用于验证合法 Atlassian Gadget 的 Servlet 过滤器,进而导致 XSS。攻击者可诱骗用户请求恶意 URL,借此在用户的浏览器中执行任意 Javascript。h3。其他 Servlet 过滤器调用 (CVE-2022-26137) 当应用程序处理请求或响应时,未经认证的远程攻击者可造成应用程序调用其他 Servlet 过滤器。Atlassian 已确认并修复已知与此漏洞相关的唯一安全问题:{*}跨源资源共享 (CORS) 绕过{*}。通过发送特别构建的 HTTP 请求,可调用用于响应 CORS 请求的 Servlet 过滤器,从而导致 CORS 绕过。攻击者可诱骗用户请求恶意 URL,借此利用受害者的权限访问易受攻击的应用程序。h3。受影响的版本:* 版本 < 7.4.17 * 7.5.x 至 7.12.x 的所有版本 * 7.13.x < 7.13.7 * 7.14.x < 7.14.3 * 7.15.x < 7.15.2 * 7.16.x < 7.16.4 * 7.17.x < 7.17.4 * 7.18.0 h3。修复版本:* 7.4.x >= 7.4.17 ([LTS|https://confluence.atlassian.com/enterprise/long-term-support-releases-948227420.html]) * 7.13.x >= 7.13.7 ([LTS|https://confluence.atlassian.com/enterprise/long-term-support-releases-948227420.html]) * 7.14.x >= 7.14.3 * 7.15.x >= 7.15.2 * 7.16.x >= 7.16.4 * 7.17.x >= 7.17.4 * 版本 >= 7.18.1 h3. 参考 [多种产品安全公告 2022-07-20|https://confluence.atlassian.com/security/multiple-products-security-advisory-cve-2022-26136-cve-2022-26137-1141493031.html] (atlassian-CONFSERVER-79476)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 Atlassian Confluence 7.4.17、7.13.7、7.14.3、7.15.2、7.16.4、7.17.4 或更新版本。

另见

https://jira.atlassian.com/browse/CONFSERVER-79476

插件详情

严重性: Critical

ID: 163307

文件名: confluence_confserver-79476.nasl

版本: 1.7

类型: remote

发布时间: 2022/7/20

最近更新时间: 2022/10/5

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-26136

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:atlassian:confluence

必需的 KB 项: installed_sw/confluence

易利用性: No known exploits are available

补丁发布日期: 2022/7/5

漏洞发布日期: 2022/7/5

参考资料信息

CVE: CVE-2022-26136

IAVA: 2022-A-0293