Drupal 9.2.x < 9.2.21 / 9.3.x < 9.3.16 Drupal Multiple Vulnerabilities (SA-CORE-2022-011)

high Nessus 插件 ID 162123

简介

远程 Web 服务器上运行的 PHP 应用程序受到多个漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 Drupal 实例为低于 9.2.21 的 9.2.x,低于 9.3.16 的 9.3.x 或低于 9.4.0-rc2 的 9.4.x。因此,该主机受到多个漏洞的影响。

- Guzzle 是一个开源的 PHP HTTP 客户端。在受影响的版本中,请求中的“Cookie”标头是敏感信息。当使用“https”方案向服务器发出请求时,若服务器以重定向到使用“http” 方案的 URI 作为响应,或向服务器发出请求时,服务器以重定向到不同主机的 URI 作为响应,则我们不应转发“Cookie”标头。在此补丁之前,只会安全删除由我们的 cookie 中间件管理的 cookie,并且不会剥离任何手动添加到初始请求的“Cookie”标头。现在,我们会一律将其剥离,并允许 cookie 中间件重新添加它认为应该存在的任何 cookie。受影响的 Guzzle 7 用户应尽快升级到 Guzzle 7.4.4 。使用 Guzzle 较早版本的受影响用户应升级到 Guzzle 6.5.7 或 7.4.4。无法升级的用户可考虑使用您自己的重定向中间件,而不是我们的方法。如果您不要求或不期望遵循重定向,则应一起禁用所有重定向。(CVE-2022-31042)

- Guzzle 是一个开源的 PHP HTTP 客户端。在受影响的版本中,请求中的“`身份验证`”标头是敏感信息。当使用“`https`”方案向服务器发出请求时,若服务器以重定向到使用“`https`” 方案的 URI 作为响应,则我们不应转发“`身份验证`”标头。这与主机变更时不转发标头的方式大致相同。在此补丁之前,“`https`”到“`https`”降级不会导致删除“`身份验证`”标头,只会导致对主机的更改。
受影响的 Guzzle 7 用户应尽快升级到 Guzzle 7.4.4 。使用 Guzzle 较早版本的受影响用户应升级到 Guzzle 6.5.7 或 7.4.4。无法升级的用户可考虑使用自己的重定向中间件。或者,如果不想或不需要重定向,用户可以一起禁用所有重定向。 (CVE-2022-31043)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级到 Drupal 9.2.21 / 9.3.16 / 9.4.0-rc2 或更高版本。

另见

https://www.drupal.org/node/1173280

https://www.drupal.org/psa-2021-06-29

https://www.drupal.org/sa-core-2022-011

https://www.drupal.org/node/3268032

http://www.nessus.org/u?480a85b9

http://www.nessus.org/u?67250a58

http://www.nessus.org/u?c8d24d6d

https://www.drupal.org/project/drupal/releases/9.2.21

https://www.drupal.org/project/drupal/releases/9.3.16

https://www.drupal.org/project/drupal/releases/9.4.0-rc2

插件详情

严重性: High

ID: 162123

文件名: drupal_9_3_16.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2022/6/10

最近更新时间: 2022/7/5

配置: 启用偏执模式, 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-31043

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

必需的 KB 项: Settings/ParanoidReport, installed_sw/Drupal

易利用性: No known exploits are available

补丁发布日期: 2022/6/10

漏洞发布日期: 2022/6/10

参考资料信息

CVE: CVE-2022-31042, CVE-2022-31043