Apache APISIX < 2.13.1 信息泄露漏洞

high Nessus 插件 ID 161734

简介

远程主机上安装的应用程序缺少供应商提供的安全更新。

描述

远程主机上安装的 Apache APISIX 版本低于 2.13.1。因此,其可能会受到信息泄露漏洞的影响,原因是由于从依存关系 lua-resty-jwt 返回的错误消息中包含敏感信息,导致 jwt-auth 插件中存在泄露用户密钥的安全问题。

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级至 Apache APISIX 2.13.1 或更新版本。

另见

https://github.com/apache/apisix/blob/release/2.13/CHANGELOG.md#2131

https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr

插件详情

严重性: High

ID: 161734

文件名: apache_apisix_2_13_1.nasl

版本: 1.2

类型: remote

系列: Misc.

发布时间: 2022/6/1

最近更新时间: 2022/6/2

配置: 启用偏执模式

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-29266

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:apisix

必需的 KB 项: installed_sw/Apache APISIX, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2022/4/15

漏洞发布日期: 2022/4/20

参考资料信息

CVE: CVE-2022-29266