Oracle Linux 7:qemu (ELSA-2022-9432)

high Nessus 插件 ID 161622

简介

远程 Oracle Linux 主机缺少一个或多个安全更新。

描述

远程 Oracle Linux 7 主机上安装的多个程序包受到 ELSA-2022-9432 公告中提及的多个漏洞影响。

- 在 QEMU 的 virtio-net 设备中发现一个释放后使用漏洞。当描述符的地址属于非直接访问区域时即会发生这种情况,原因是在取消映射 virtqueue elem 后设置了 num_buffers。恶意来宾用户可利用此缺陷造成 QEMU 崩溃,从而导致拒绝服务情形或可能使用 QEMU 进程的权限在主机上执行代码。(CVE-2021-3748)

- 在 QEMU 的 virtio-net 设备中发现一个缺陷。修复 CVE-2021-3748时无意间引入了此缺陷,该缺陷在出错时忘记取消映射缓存的 virtqueue 元素,从而导致内存泄漏和其他意外结果。受影响的 QEMU 版本:6.2.0. (CVE-2022-26353)

- 在 QEMU 的 vhost-vsock 设备中发现一个缺陷。如果出错,无效元素无法在释放内存前从 virtqueue 分离,从而导致内存泄漏和其他意外结果。
QEMU 6.2.0 及更低版本会受到影响。(CVE-2022-26354)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的程序包。

另见

https://linux.oracle.com/errata/ELSA-2022-9432.html

插件详情

严重性: High

ID: 161622

文件名: oraclelinux_ELSA-2022-9432.nasl

版本: 1.3

类型: local

代理: unix

发布时间: 2022/5/27

最近更新时间: 2023/1/9

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: High

分数: 7.3

CVSS v2

风险因素: Medium

基本分数: 6.9

时间分数: 5.1

矢量: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-3748

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:oracle:linux:7, p-cpe:/a:oracle:linux:ivshmem-tools, p-cpe:/a:oracle:linux:qemu, p-cpe:/a:oracle:linux:qemu-block-gluster, p-cpe:/a:oracle:linux:qemu-block-iscsi, p-cpe:/a:oracle:linux:qemu-block-rbd, p-cpe:/a:oracle:linux:qemu-common, p-cpe:/a:oracle:linux:qemu-img, p-cpe:/a:oracle:linux:qemu-kvm, p-cpe:/a:oracle:linux:qemu-kvm-core, p-cpe:/a:oracle:linux:qemu-system-aarch64, p-cpe:/a:oracle:linux:qemu-system-aarch64-core, p-cpe:/a:oracle:linux:qemu-system-x86, p-cpe:/a:oracle:linux:qemu-system-x86-core

必需的 KB 项: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/rpm-list, Host/RedHat/release

易利用性: No known exploits are available

补丁发布日期: 2022/5/26

漏洞发布日期: 2022/3/16

参考资料信息

CVE: CVE-2021-3748, CVE-2022-26353, CVE-2022-26354