GitLab 14.4.x < 14.7.7/14.8.x < 14.8.5/14.9.x < 14.8.2 XSS

medium Nessus 插件 ID 159823

简介

远程 Web 服务器上运行的源代码控制应用程序受到一个跨站脚本漏洞的影响。

描述

GitLab CE/EE 14.4 至 14.7.7、14.8 至 14.8.5 以及 14.9 至 14.9.2 所有版本中都存在不当中和用户输入漏洞,从而允许攻击者通过在便签中注入 HTML 来利用 XSS。

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 GitLab 14.7.7、14.8.5、14.9.2 或更新版本。

另见

http://www.nessus.org/u?eea093a9

插件详情

严重性: Medium

ID: 159823

文件名: gitlab_cve-2022-1175.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2022/4/18

最近更新时间: 2022/7/26

风险信息

VPR

风险因素: Low

分数: 3.8

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.4

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:POC/RL:OF/RC:C

CVSS 分数来源: CVE-2022-1175

CVSS v3

风险因素: Medium

基本分数: 6.1

时间分数: 5.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:gitlab:gitlab

必需的 KB 项: installed_sw/GitLab

可利用: true

易利用性: Exploits are available

补丁发布日期: 2022/3/31

漏洞发布日期: 2022/3/31

参考资料信息

CVE: CVE-2022-1175

IAVA: 2022-A-0131-S