GitLab < 14.7.7/14.8.x < 14.8.5/ 14.9.x < 14.9.2 多个漏洞

medium Nessus 插件 ID 159818

简介

远程 Web 服务器上运行的一个源代码控制应用程序受到多个漏洞影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 GitLab 实例为低于 14.8.5 的 14.7.7 14.8.x 版本或低于 14.9.2 的 14.9.x 版本。因此,该应用程序受到以下漏洞的影响:

- 攻击者可向 GitLab CE/EE 中的运行程序添加大量标签,从而降低 GitLab 的性能。(CVE-2022-1099)

- 当 CI/CD 配置中的 include 指令失败时,GitLab CE/EE 中的遗漏筛选错误消息漏洞会导致暴露敏感信息。(CVE-2022-1120)

- GitLab CE/EE 随附的 GitLab Pages 中缺少适当超时,从而允许攻击者造成无无限量的资源消耗。(CVE-2022-1121)

- 未对记录的异常消息进行审查会导致记录无效 URL 中的潜在敏感值。
(CVE-2022-1157)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 GitLab 14.7.7、14.8.5、14.9.2 或更新版本。

另见

http://www.nessus.org/u?35c16f9f

http://www.nessus.org/u?b85d5630

插件详情

严重性: Medium

ID: 159818

文件名: gitlab_14_9_2.nasl

版本: 1.4

类型: remote

系列: CGI abuses

发布时间: 2022/4/18

最近更新时间: 2022/7/26

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 4

时间分数: 3

矢量: AV:N/AC:L/Au:S/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-1120

CVSS v3

风险因素: Medium

基本分数: 6.5

时间分数: 5.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:gitlab:gitlab

必需的 KB 项: installed_sw/GitLab

易利用性: No known exploits are available

补丁发布日期: 2022/3/31

漏洞发布日期: 2022/3/31

参考资料信息

CVE: CVE-2022-1099, CVE-2022-1120, CVE-2022-1121, CVE-2022-1157

IAVA: 2022-A-0131-S