PHP < 4.3.10 / 5.0.3 多种漏洞

high Nessus 插件 ID 15973

简介

远程 Web 服务器采用的 PHP 版本可能受到多种漏洞的影响。

描述

根据其标题,远程主机上安装的 PHP 版本低于 4.3.10 / 5.0.3。因此,它受到多种安全问题的影响,在某些情况下,如果攻击者可将任意数据传递给某些函数或 bypass safe_mode,可允许攻击者在远程主机上执行任意代码。

解决方案

请升级到 PHP 5.0.3 或 4.3.10。

另见

http://www.php.net/ChangeLog-5.php#5.0.3

插件详情

严重性: High

ID: 15973

文件名: php45_multiple_flaws.nasl

版本: 1.25

类型: remote

系列: CGI abuses

发布时间: 2004/12/15

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.8

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2004/12/14

漏洞发布日期: 2004/11/23

参考资料信息

CVE: CVE-2004-1018, CVE-2004-1019, CVE-2004-1020, CVE-2004-1063, CVE-2004-1064, CVE-2004-1065

BID: 11964, 11981, 11992, 12045

CWE: 20