Debian DSA-5111-1:zlib - 安全更新

high Nessus 插件 ID 159466

语言:

简介

远程 Debian 主机缺少与安全相关的更新。

描述

远程 Debian 10/11 主机上安装的多个程序包受到 dsa-5111 公告中提及的一个漏洞影响。

- 如果输入具有许多远程匹配项,则 zlib 1.2.12 之前版本会在压缩时造成内存损坏。(CVE-2018-25032)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号来判断。

解决方案

升级 zlib 程序包。

对于稳定发行版本 (bullseye),已在版本 1 中修复此问题

另见

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1008265

https://security-tracker.debian.org/tracker/source-package/zlib

https://www.debian.org/security/2022/dsa-5111

https://security-tracker.debian.org/tracker/CVE-2018-25032

https://packages.debian.org/source/buster/zlib

https://packages.debian.org/source/bullseye/zlib

插件详情

严重性: High

ID: 159466

文件名: debian_DSA-5111.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2022/4/1

最近更新时间: 2022/4/1

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 6.1

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2018-25032

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:lib32z1, p-cpe:/a:debian:debian_linux:lib32z1-dev, p-cpe:/a:debian:debian_linux:lib64z1, p-cpe:/a:debian:debian_linux:lib64z1-dev, p-cpe:/a:debian:debian_linux:libn32z1, p-cpe:/a:debian:debian_linux:libn32z1-dev, p-cpe:/a:debian:debian_linux:zlib1g, p-cpe:/a:debian:debian_linux:zlib1g-dbg, p-cpe:/a:debian:debian_linux:zlib1g-dev, p-cpe:/a:debian:debian_linux:zlib1g-udeb, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2022/4/1

漏洞发布日期: 2022/3/25

参考资料信息

CVE: CVE-2018-25032