Oracle MySQL Connectors(2022 年 1 月 CPU)

high Nessus 插件 ID 156889

简介

远程主机受到多个漏洞的影响

描述

远程主机上安装的 MySQL Server 8.0.27 及之前版本受到 2022 年 1 月 CPU 公告中提及的多个漏洞影响。

- Oracle MySQL 的 MySQL Connectors 产品中存在漏洞(组件:Connector/C++ (OpenSSL))。支持的版本中受影响的是 8.0.27 和较早版本。难以利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 MySQL Connector。成功攻击此漏洞可导致在未经授权的情况下访问重要数据或完整访问所有可供访问的 MySQL Connectors 数据,并且未经授权即可造成 MySQL Server 挂起或频繁崩溃(完全 DOS)。(CVE-2021-3712)

- Oracle MySQL 的 MySQL Connectors 产品中存在漏洞(组件:Connector/C)。支持的版本中受影响的是 8.0.27 和较早版本。难以利用的漏洞允许高权限攻击者通过多种协议进行网络访问,从而破坏 MySQL Connectors。成功利用此漏洞进行攻击可导致接管 MySQL Connector。(CVE-2022-21363)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

请根据 2022 年 1 月 Oracle 关键补丁更新公告应用相应补丁。

另见

https://www.oracle.com/a/tech/docs/cpujan2022cvrf.xml

https://www.oracle.com/security-alerts/cpujan2022.html#AppendixMSQL

插件详情

严重性: High

ID: 156889

文件名: oracle_mysql_connectors_cpu_jan_2022.nasl

版本: 1.6

类型: local

代理: windows, macosx, unix

系列: Misc.

发布时间: 2022/1/20

最近更新时间: 2022/5/6

配置: 启用彻底检查

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6

时间分数: 4.4

矢量: AV:N/AC:M/Au:S/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-21363

CVSS v3

风险因素: High

基本分数: 7.4

时间分数: 6.4

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H

时间矢量: E:U/RL:O/RC:C

CVSS 分数来源: CVE-2021-3712

漏洞信息

CPE: cpe:/a:oracle:mysql_connectors

必需的 KB 项: installed_sw/MySQL Connector

易利用性: No known exploits are available

补丁发布日期: 2022/1/18

漏洞发布日期: 2022/1/18

参考资料信息

CVE: CVE-2021-3712, CVE-2022-21363

IAVA: 2022-A-0030