Adobe Reader < 17.011.30207 / 20.004.30020 / 21.011.20039 多个漏洞 (APSB22-01) (macOS)

high Nessus 插件 ID 156667

简介

远程 macOS 主机上安装的 Adobe Reader 版本受到多个漏洞的影响。

描述

远程 macOS 主机上安装的 Adobe Reader 版本低于 17.011.30207、20.004.30020 或 21.011.20039。因此,该主机受到多个漏洞的影响。

- Acrobat Reader DC 21.007.20099(和更早版本)、Acrobat Reader DC 20.004.30017(和更早版本)以及 Acrobat Reader DC 17.011.30204(和更早版本)均会在处理 Format 事件操作时受到一个释放后使用漏洞的影响,从而可能造成在当前用户的上下文中执行任意代码。若要恶意利用此问题,需要进行用户交互,其中受害者必须打开恶意文件。(CVE-2021-44701、CVE-2021-44704、CVE-2021-44705、CVE-2021-44706、CVE-2021-44710、CVE-2021-45062、CVE-2021-45064)

- Acrobat Reader DC ActiveX Control 21.007.20099 (和更早版本)、Acrobat Reader DC ActiveX Control 20.004.30017(和更早版本)以及 Acrobat Reader DC ActiveX Control 17.011.30204(和更早版本)均会受到一个信息泄露漏洞的影响。An unauthenticated attacker could leverage this vulnerability to obtain NTLMv2 credentials. 若要恶意利用此问题,需要进行用户交互,其中受害者必须访问攻击者控制的网页。(CVE-2021-44702)

- Acrobat Reader DC 21.007.20099(和更早版本)、Acrobat Reader DC 20.004.30017(和更早版本)以及 Acrobat Reader DC 17.011.30204(和更早版本)均会受到因不安全处理所构建文件产生的一个堆栈缓冲区溢出漏洞影响,从而可能造成在当前用户的上下文中执行任意代码。利用此问题需要用户交互,受害者必须打开恶意文件。(CVE-2021-44703)

- Acrobat Reader DC 21.007.20099(和更早版本)、Acrobat Reader DC 20.004.30017(和更早版本)以及 Acrobat Reader DC 17.011.30204(和更早版本)均会受到一个越界写入漏洞的影响,从而可能造成在当前用户的上下文中执行任意代码。若要恶意利用此问题,需要进行用户交互,其中受害者必须打开恶意文件。(CVE-2021-44707、CVE-2021-45061、CVE-2021-45068)

- Acrobat Reader DC 21.007.20099(和更早版本)、Acrobat Reader DC 20.004.30017(和更早版本)以及 Acrobat Reader DC 17.011.30204(和更早版本)均会受到因不安全处理所构建文件产生的一个堆溢出漏洞影响,从而可能造成在当前用户的上下文中执行任意代码。利用此问题需要用户交互,受害者必须打开恶意文件。(CVE-2021-44708、CVE-2021-44709)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级版本到 17.011.30207 / 20.004.30020 / 21.011.20039 或更高版本。

另见

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/121.html

https://cwe.mitre.org/data/definitions/122.html

https://cwe.mitre.org/data/definitions/125.html

https://cwe.mitre.org/data/definitions/190.html

https://cwe.mitre.org/data/definitions/284.html

https://cwe.mitre.org/data/definitions/416.html

https://cwe.mitre.org/data/definitions/476.html

https://cwe.mitre.org/data/definitions/657.html

https://cwe.mitre.org/data/definitions/787.html

https://cwe.mitre.org/data/definitions/788.html

https://cwe.mitre.org/data/definitions/824.html

https://helpx.adobe.com/security/products/acrobat/apsb22-01.html

插件详情

严重性: High

ID: 156667

文件名: macos_adobe_reader_apsb22-01.nasl

版本: 1.7

类型: local

代理: macosx

发布时间: 2022/1/12

最近更新时间: 2022/10/18

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 8.1

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:H/RL:OF/RC:C

CVSS 分数来源: CVE-2021-45062

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 7.5

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

CVSS 分数来源: CVE-2021-45068

漏洞信息

CPE: cpe:/a:adobe:acrobat_reader

必需的 KB 项: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Reader

可利用: true

易利用性: Exploits are available

补丁发布日期: 2022/1/11

漏洞发布日期: 2022/1/11

参考资料信息

CVE: CVE-2021-44701, CVE-2021-44702, CVE-2021-44703, CVE-2021-44704, CVE-2021-44705, CVE-2021-44706, CVE-2021-44707, CVE-2021-44708, CVE-2021-44709, CVE-2021-44710, CVE-2021-44711, CVE-2021-44712, CVE-2021-44713, CVE-2021-44714, CVE-2021-44715, CVE-2021-44739, CVE-2021-44740, CVE-2021-44741, CVE-2021-44742, CVE-2021-45060, CVE-2021-45061, CVE-2021-45062, CVE-2021-45063, CVE-2021-45064, CVE-2021-45067, CVE-2021-45068

IAVA: 2022-A-0013-S

CWE: 20, 121, 122, 125, 190, 284, 416, 476, 657, 787, 788, 824