Debian DSA-5039-1:wordpress - 安全更新

high Nessus 插件 ID 156616

简介

远程 Debian 主机上缺少一个或多个与安全性相关的更新。

描述

远程 Debian 10/11 主机上安装的程序包受到 dsa-5039 公告中提及的多个漏洞影响。

- WordPress 是一个以 PHP 编写并搭配 MariaDB 数据库的免费开源内容管理系统。由于 WP_Query 中存在清理不当问题,在某些情况下,可通过以某种方式使用插件或主题来发动 SQL 注入攻击。此漏洞已在 WordPress 5.8.3 版本中修复。
受影响的较旧版本(3.7.37 之前版本)也可通过安全版本进行修复。我们强烈建议您保持启用自动更新。目前尚无针对此漏洞的解决方案。
(CVE-2022-21661)

- WordPress 是一个以 PHP 编写并搭配 MariaDB 数据库的免费开源内容管理系统。WordPress 核心中经身份验证的低权限用户(如作者)可以执行 JavaScript/发动存储的 XSS 攻击,进而影响到高权限用户。此漏洞已在 WordPress 5.8.3 版本中修复。受影响的较旧版本(3.7.37 之前版本)也可通过安全版本进行修复。我们强烈建议您保持启用自动更新。目前尚无针对此问题的解决方案。(CVE-2022-21662)

- WordPress 是一个以 PHP 编写并搭配 MariaDB 数据库的免费开源内容管理系统。在多站点上,具有超级管理员角色的用户可在某些情况下通过注入对象来绕过显式/额外强化。此漏洞已在 WordPress 5.8.3 版本中修复。受影响的较旧版本(3.7.37 之前版本)也可通过安全版本进行修复。我们强烈建议您保持启用自动更新。目前尚无针对此问题的解决方案。(CVE-2022-21663)

- WordPress 是一个以 PHP 编写并搭配 MariaDB 数据库的免费开源内容管理系统。由于不当清理其中一个类,因此可能会执行非预期的 SQL 查询。此漏洞已在 WordPress 5.8.3 版本中修复。受影响的较旧版本(4.1.34 之前版本)也可通过安全版本进行修复。我们强烈建议您保持启用自动更新。目前尚无针对此问题的解决方案。(CVE-2022-21664)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级 wordpress 程序包。

对于稳定发行版本 (bullseye),这些问题已在 5.7.5+dfsg1-0+deb11u1 版本中解决。

另见

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1003243

https://security-tracker.debian.org/tracker/source-package/wordpress

https://www.debian.org/security/2022/dsa-5039

https://security-tracker.debian.org/tracker/CVE-2022-21661

https://security-tracker.debian.org/tracker/CVE-2022-21662

https://security-tracker.debian.org/tracker/CVE-2022-21663

https://security-tracker.debian.org/tracker/CVE-2022-21664

https://packages.debian.org/source/buster/wordpress

https://packages.debian.org/source/bullseye/wordpress

插件详情

严重性: High

ID: 156616

文件名: debian_DSA-5039.nasl

版本: 1.4

类型: local

代理: unix

发布时间: 2022/1/11

最近更新时间: 2022/1/20

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

CVSS 分数来源: CVE-2022-21664

VPR

风险因素: Medium

分数: 6.1

CVSS v2

风险因素: Medium

基本分数: 6.5

时间分数: 5.1

矢量: AV:N/AC:L/Au:S/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.9

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:wordpress, p-cpe:/a:debian:debian_linux:wordpress-l10n, p-cpe:/a:debian:debian_linux:wordpress-theme-twentynineteen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentyseventeen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentysixteen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwenty, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwentyone, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2022/1/11

漏洞发布日期: 2022/1/11

参考资料信息

CVE: CVE-2022-21661, CVE-2022-21662, CVE-2022-21663, CVE-2022-21664

IAVA: 2022-A-0003