Ubuntu 18.04 LTS / 20.04 LTS / 21.04 / 21.10:Flatpak 漏洞 (USN-5191-1)

high Nessus 插件 ID 156055

语言:

简介

远程 Ubuntu 主机缺少安全更新。

描述

远程 Ubuntu 18.04 LTS / 20.04 LTS / 21.04 / 21.10 主机上安装的程序包受到 USN-5191-1 公告中提及的漏洞的影响。

- Flatpak 是一个用于在 Linux 上构建、分发和运行沙盒式桌面应用程序的系统。在 1.10.4 和 1.12.0之前的版本中,可直接访问 AF_UNIX 套接字的 Flatpak 应用程序(例如在 Wayland、Pipewire 或 pipewire-pulse 中使用) 可诱骗门户网站和其他主机操作系统服务将 Flatpak 应用程序视为非沙盒隔离的普通主机操作系统进程。为此,他们可以使用未被 Flatpak 的拒绝列表 seccomp 过滤器阻止的与挂载相关的最近 syscall 来操纵 VFS,以便替换构建的「/.flatpak-info」或使该文件完全消失。充当 AF_UNIX 套接字客户端的 Flatpak 应用程序(例如在 Wayland、Pipewire 或 pipewire-pulse 中使用)可提升相应服务认为 Flatpak 应用程序具有的权限。请注意,完全在 D-Bus 会话总线(用户总线)、系统总线或可访问性总线上运行的协议不受此影响。这是由于使用了代理进程「xdg-dbus-proxy」,在与这些总线交互时,其 VFS 无法被 Flatpak 应用程序操纵。目前已有针对版本 1.10.4 和 1.12.0的修补程序,截至发布时,正在计划 1.8.2 版的修补程序。除了升级到修补过的版本外,没有其他变通方案。(CVE-2021-41133)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新受影响的程序包。

另见

https://ubuntu.com/security/notices/USN-5191-1

插件详情

严重性: High

ID: 156055

文件名: ubuntu_USN-5191-1.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/12/14

最近更新时间: 2021/12/14

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

风险信息

CVSS 分数来源: CVE-2021-41133

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 4.6

时间分数: 3.4

矢量: AV:L/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 6.8

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:21.04, cpe:/o:canonical:ubuntu_linux:21.10, p-cpe:/a:canonical:ubuntu_linux:flatpak, p-cpe:/a:canonical:ubuntu_linux:flatpak-tests, p-cpe:/a:canonical:ubuntu_linux:gir1.2-flatpak-1.0, p-cpe:/a:canonical:ubuntu_linux:libflatpak-dev, p-cpe:/a:canonical:ubuntu_linux:libflatpak0

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2021/12/14

漏洞发布日期: 2021/10/8

参考资料信息

CVE: CVE-2021-41133

USN: 5191-1