Ubuntu 18.04 LTS:libmodbus 漏洞 (USN-5173-1)

critical Nessus 插件 ID 155944

语言:

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 18.04 LTS 主机上安装的程序包受到 USN-5173-1 公告中提及的多个漏洞的影响。

- 在版本低于 3.0.7 的 libmodbus 和版本低于 3.1.5 的 3.1.x 中发现问题。MODBUS_FC_WRITE_MULTIPLE_COILS 案例存在越界读取漏洞,亦称 VD-1302。(CVE-2019-14462)

- 在版本低于 3.0.7 的 libmodbus 和版本低于 3.1.5 的 3.1.x 中发现问题。MODBUS_FC_WRITE_MULTIPLE_REGISTERS 案例存在越界读取漏洞,亦称 VD-1301。(CVE-2019-14463)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新受影响的 libmodbus-dev 和/或 libmodbus5 程序包。

另见

https://ubuntu.com/security/notices/USN-5173-1

插件详情

严重性: Critical

ID: 155944

文件名: ubuntu_USN-5173-1.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/12/8

最近更新时间: 2021/12/8

支持的传感器: Nessus Agent

风险信息

CVSS 分数来源: CVE-2019-14463

VPR

风险因素: Medium

分数: 5.2

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 4.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.1

时间分数: 7.9

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libmodbus-dev, p-cpe:/a:canonical:ubuntu_linux:libmodbus5

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2021/12/6

漏洞发布日期: 2019/7/31

参考资料信息

CVE: CVE-2019-14462, CVE-2019-14463

USN: 5173-1