NewStart CGSL MAIN 6.02:mariadb-connector-c 多个漏洞 (NS-SA-2021-0123)

high Nessus 插件 ID 154600

语言:

简介

远程 NewStart CGSL 主机受到多个漏洞影响。

描述

运行 MAIN 6.02 版本的远程 NewStart CGSL 主机上安装的 mariadb-connector-c 程序包受到多个漏洞的影响:

- MariaDB Connector/C 3.1.8 之前版本的 libmariadb/mariadb_lib.c 未正确验证从服务器接收的 OK 数据包的内容。注意:尽管 mariadb_lib.c 最初基于 MySQL 随附的代码,但此问题不影响 Oracle 支持的任何 MySQL 组件。(CVE-2020-13249)

- Oracle MySQL 的 MySQL Client 产品中存在漏洞(组件:C API)。支持的版本中受影响的是 5.6.46 和较早版本、5.7.28 和较早版本以及 8.0.18 和较早版本。难以利用的漏洞允许具备网络访问权限的未经身份验证的攻击者通过多种协议破坏 MySQL Client。
若成功攻击此漏洞,可在未经授权的情况下造成 MySQL Client 挂起或频繁出现崩溃(完整 DOS)。CVSS 3.0 基本分数 5.9(可用性影响)。CVSS 向量:(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H)。(CVE-2020-2574)

- Oracle MySQL 的 MySQL Client 产品中存在漏洞(组件:C API)。支持的版本中受影响的是 5.6.47 和较早版本、5.7.27 和较早版本以及 8.0.17 和较早版本。难以利用的漏洞允许低权限攻击者通过多种协议进行网络访问,从而破坏 MySQL Client。
若成功攻击此漏洞,可在未经授权的情况下造成 MySQL Client 挂起或频繁出现崩溃(完整 DOS)。CVSS 3.0 基本分数 5.3(可用性影响)。CVSS 向量:(CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H)。(CVE-2020-2752)

- Oracle MySQL 的 MySQL Client 产品中存在漏洞(组件:C API)。支持的版本中受影响的是 5.6.47 和较早版本、5.7.29 和较早版本以及 8.0.18 和较早版本。难以利用的漏洞允许具备网络访问权限的未经身份验证的攻击者通过多种协议破坏 MySQL Client。
成功攻击此漏洞可导致在未经授权的境况下,对 MySQL Client 可访问数据子集进行读取访问。CVSS 3.0 基本分数 3.7(机密性影响)。CVSS 向量:
(CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)。(CVE-2020-2922)

- Oracle MySQL 的 MySQL Client 产品中存在漏洞(组件:C API)。支持的版本中受影响的是 5.6.47 和较早版本、5.7.29 和较早版本以及 8.0.19 和较早版本。难以利用的漏洞允许具备网络访问权限的未经身份验证的攻击者通过多种协议破坏 MySQL Client。
成功攻击此漏洞可导致在未经授权的境况下,对 MySQL Client 可访问数据子集进行读取访问。CVSS 3.1 基本分数 3.7(机密性影响)。CVSS 向量:
(CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)。(CVE-2021-2007)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级易受攻击的 CGSL mariadb-connector-c 程序包。请注意,更新后的程序包尚未发布。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0123

http://security.gd-linux.com/info/CVE-2020-13249

http://security.gd-linux.com/info/CVE-2020-2574

http://security.gd-linux.com/info/CVE-2020-2752

http://security.gd-linux.com/info/CVE-2020-2922

http://security.gd-linux.com/info/CVE-2021-2007

插件详情

严重性: High

ID: 154600

文件名: newstart_cgsl_NS-SA-2021-0123_mariadb-connector-c.nasl

版本: 1.3

类型: local

发布时间: 2021/10/28

最近更新时间: 2022/12/5

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2020-13249

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:zte:cgsl_main:mariadb-connector-c, p-cpe:/a:zte:cgsl_main:mariadb-connector-c-config, p-cpe:/a:zte:cgsl_main:mariadb-connector-c-debuginfo, p-cpe:/a:zte:cgsl_main:mariadb-connector-c-debugsource, p-cpe:/a:zte:cgsl_main:mariadb-connector-c-devel, p-cpe:/a:zte:cgsl_main:mariadb-connector-c-devel-debuginfo, cpe:/o:zte:cgsl_main:6

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2021/9/24

漏洞发布日期: 2020/1/15

参考资料信息

CVE: CVE-2020-2574, CVE-2020-2752, CVE-2020-2922, CVE-2020-13249, CVE-2021-2007

IAVA: 2020-A-0021-S, 2020-A-0143, 2021-A-0038

CEA-ID: CEA-2021-0004