NewStart CGSL CORE 5.05 / MAIN 5.05 : e2fsprogs 多个漏洞 (NS-SA-2021-0145)

medium Nessus 插件 ID 154586

语言:

简介

远程 NewStart CGSL 主机受到多个漏洞影响。

描述

运行 CORE 5.05 / MAIN 5.05 版本的远程 NewStart CGSL 主机上安装的 e2fsprogs 程序包受到多个漏洞的影响:

- E2fsprogs 1.45.3 的配额文件功能中存在可利用的代码执行漏洞。特别构建的 ext4 分区可造成堆上越界写入,从而导致代码执行。攻击者可损坏分区,从而触发此漏洞。(CVE-2019-5094)

- E2fsprogs e2fsck 1.45.4 的目录重新哈希功能中存在代码执行漏洞。
特别构建的 ext4 目录可造成堆栈上越界写入,从而导致代码执行。攻击者可损坏分区,从而触发此漏洞。(CVE-2019-5188)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级易受攻击的 CGSL e2fsprogs 程序包。请注意,更新后的程序包尚未发布。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0145

http://security.gd-linux.com/info/CVE-2019-5094

http://security.gd-linux.com/info/CVE-2019-5188

插件详情

严重性: Medium

ID: 154586

文件名: newstart_cgsl_NS-SA-2021-0145_e2fsprogs.nasl

版本: 1.2

类型: local

发布时间: 2021/10/27

最近更新时间: 2021/10/27

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 4.6

时间分数: 3.4

矢量: AV:L/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2019-5188

CVSS v3

风险因素: Medium

基本分数: 6.7

时间分数: 5.8

矢量: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:zte:cgsl_core:e2fsprogs, p-cpe:/a:zte:cgsl_core:e2fsprogs-devel, p-cpe:/a:zte:cgsl_core:e2fsprogs-libs, p-cpe:/a:zte:cgsl_core:e2fsprogs-static, p-cpe:/a:zte:cgsl_core:libcom_err, p-cpe:/a:zte:cgsl_core:libcom_err-devel, p-cpe:/a:zte:cgsl_core:libss, p-cpe:/a:zte:cgsl_core:libss-devel, p-cpe:/a:zte:cgsl_main:e2fsprogs, p-cpe:/a:zte:cgsl_main:e2fsprogs-devel, p-cpe:/a:zte:cgsl_main:e2fsprogs-libs, p-cpe:/a:zte:cgsl_main:e2fsprogs-static, p-cpe:/a:zte:cgsl_main:libcom_err, p-cpe:/a:zte:cgsl_main:libcom_err-devel, p-cpe:/a:zte:cgsl_main:libss, p-cpe:/a:zte:cgsl_main:libss-devel, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2021/9/24

漏洞发布日期: 2019/9/24

参考资料信息

CVE: CVE-2019-5094, CVE-2019-5188