NewStart CGSL CORE 5.05 / MAIN 5.05 : openwsman 漏洞 (NS-SA-2021-0174)

high Nessus 插件 ID 154549

语言:

简介

远程 NewStart CGSL 主机受到一个漏洞影响。

描述

运行 CORE 5.05 / MAIN 5.05 版本的远程 NewStart CGSL 主机上安装的 openwsman 程序包受到一个漏洞的影响:

- Openwsman 2.6.9 及其之前版本在解析特别构建的 HTTP 请求时容易受到 process_connection() 中无限循环的攻击。未经身份验证的远程攻击者可利用此漏洞,发送恶意 HTTP 请求至 openwsman 服务器,从而造成拒绝服务。
(CVE-2019-3833)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级易受攻击的 CGSL openwsman 程序包。请注意,更新后的程序包尚未发布。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0174

http://security.gd-linux.com/info/CVE-2019-3833

插件详情

严重性: High

ID: 154549

文件名: newstart_cgsl_NS-SA-2021-0174_openwsman.nasl

版本: 1.2

类型: local

发布时间: 2021/10/27

最近更新时间: 2021/10/27

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2019-3833

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:zte:cgsl_core:libwsman-devel, p-cpe:/a:zte:cgsl_core:libwsman1, p-cpe:/a:zte:cgsl_core:openwsman-client, p-cpe:/a:zte:cgsl_core:openwsman-perl, p-cpe:/a:zte:cgsl_core:openwsman-python, p-cpe:/a:zte:cgsl_core:openwsman-ruby, p-cpe:/a:zte:cgsl_core:openwsman-server, p-cpe:/a:zte:cgsl_main:libwsman-devel, p-cpe:/a:zte:cgsl_main:libwsman1, p-cpe:/a:zte:cgsl_main:openwsman-client, p-cpe:/a:zte:cgsl_main:openwsman-perl, p-cpe:/a:zte:cgsl_main:openwsman-python, p-cpe:/a:zte:cgsl_main:openwsman-ruby, p-cpe:/a:zte:cgsl_main:openwsman-server, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2021/9/24

漏洞发布日期: 2019/3/12

参考资料信息

CVE: CVE-2019-3833