PHP 8.0.x < 8.0.12

high Nessus 插件 ID 154296

简介

远程 Web 服务器上运行的 PHP 版本受到一个漏洞的影响。

描述

远程主机上安装的 PHP 版本低于 8.0.12,因此受到版本 8.0.12 公告中提及的漏洞的影响。

- 在 PHP 版本 7.3.x 到 7.3.31 以及版本低于 7.4.25 的 7.4.x 和版本低于 8.0.12 的 8.0.x 中,如果在运行 PHP FPM SAPI 的同时以 root 用户身份运行主 FPM 后台程序进程并以低权限用户身份运行子工作线程,则子进程可以访问与主进程共享的内存并向其写入,同时修改内存,从而导致根进程执行无效的内存读取和写入,攻击者可利用此漏洞将特权从本地非特权用户提升到 root 用户。
(CVE-2021-21703)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级至 PHP 8.0.12 或更高版本。

另见

http://bugs.php.net/81026

http://php.net/ChangeLog-8.php#8.0.12

插件详情

严重性: High

ID: 154296

文件名: php_8_0_12.nasl

版本: 1.7

类型: remote

系列: CGI abuses

发布时间: 2021/10/21

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.9

时间分数: 5.1

矢量: AV:L/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-21703

CVSS v3

风险因素: High

基本分数: 7

时间分数: 6.1

矢量: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

易利用性: No known exploits are available

补丁发布日期: 2021/10/21

漏洞发布日期: 2021/10/21

参考资料信息

CVE: CVE-2021-21703

IAVA: 2021-A-0503