Ubuntu 18.04 LTS:Mercurial 漏洞 (USN-5102-1)

critical Nessus 插件 ID 153857
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 18.04 LTS 主机上安装的程序包受到 USN-5102-1 公告中提及的多个漏洞的影响。

- 在低于 4.7.2 的 Mercurial 版本中,在解析格式错误的清单条目期间,cext/manifest.c 中存在越界读取。(CVE-2018-17983)

- 在低于 4.9 的 Mercurial 版本中发现一个缺陷。可使用符号链接和子存储库破解 Mercurial 的路径检查逻辑,并在存储库之外写入文件。(CVE-2019-3902)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新受影响的 mercurial 和/或 mercurial-common 程序包。

另见

https://ubuntu.com/security/notices/USN-5102-1

插件详情

严重性: Critical

ID: 153857

文件名: ubuntu_USN-5102-1.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/10/4

最近更新时间: 2021/10/4

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2018-17983

VPR

风险因素: Medium

分数: 5.2

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 4.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.1

时间分数: 7.9

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:mercurial, p-cpe:/a:canonical:ubuntu_linux:mercurial-common

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2021/10/4

漏洞发布日期: 2018/10/4

参考资料信息

CVE: CVE-2018-17983, CVE-2019-3902

USN: 5102-1