Fortinet FortiOS <= 6.2.9 / 6.4.x <= 6.4.6 / 7.0.0 缓冲区下界之下写入漏洞 (FG-IR-21-046)

high Nessus 插件 ID 152514

简介

远程主机受到缓冲区下界之下写入漏洞的影响。

描述

远程主机正在运行的 FortiOS 版本低于或等于 6.2.9 版,或为低于或等于 6.4.6 的 6.4.x 版,或为 7.0.0 版。因此,它受到 FortiOS 固件验证例程中一个缓冲区下界之下写入漏洞的影响,位于邻近网络的攻击者可利用此漏洞,通过特别构建的固件映像执行任意代码。

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级到 Fortinet FortiOS 6.2.10 / 6.4.7 / 7.0.1 或更高版本。

另见

https://www.fortiguard.com/psirt/FG-IR-21-046

插件详情

严重性: High

ID: 152514

文件名: fortios_FG-IR-21-046.nasl

版本: 1.5

类型: local

系列: Firewalls

发布时间: 2021/8/12

最近更新时间: 2022/2/4

风险信息

CVSS 分数来源: CVE-2021-24018

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 5.8

时间分数: 4.3

矢量: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:o:fortinet:fortios:*:*:*:*:*:*:*:*

必需的 KB 项: Host/Fortigate/version

易利用性: No known exploits are available

补丁发布日期: 2021/8/3

漏洞发布日期: 2021/8/3

参考资料信息

CVE: CVE-2021-24018

IAVA: 2021-A-0368-S