Drupal 7.x < 7.82 / 8.9.x < 8.9.17 / 9.1.x < 9.1.11 / 9.2.x < 9.2.2 Drupal 漏洞 (SA-CORE-2021-004)

high Nessus 插件 ID 151932
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 应用程序受到一个漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 Drupal 实例为低于 7.82 的 7.x,低于 8.9.17 的 8.9.x、低于 9.1.11 的 9.1.x 或低于 9.2.2 的 9.2.x。因此,该操作系统受到漏洞的影响。

- Drupal 项目使用的 pear Archive_Tar 库已经发布一项安全更新,会对 Drupal 产生影响。此漏洞已得到缓解,原因是 Drupal 核心使用的 Archive_Tar 库不易受到影响,因为它不支持符号链接。如果 contrib 或 custom 代码使用该库提取来自潜在不受信任来源的 tar 存档(例如 .tar、.tar.gz、.bz2 或 .tlz),则该漏洞可能遭到利用。Drupal Steward 中不涵盖此公告。(CVE-2021-32610)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级版本到 Drupal 7.82 / 8.9.17 / 9.1.11 / 9.2.2 或更高版本。

另见

https://www.drupal.org/sa-core-2021-004

https://www.drupal.org/project/drupal/releases/7.82

https://www.drupal.org/project/drupal/releases/8.9.17

https://www.drupal.org/project/drupal/releases/9.1.11

https://www.drupal.org/project/drupal/releases/9.2.2

https://www.drupal.org/steward

插件详情

严重性: High

ID: 151932

文件名: drupal_9_2_2.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2021/7/22

最近更新时间: 2021/8/19

依存关系: drupal_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2021-32610

VPR

风险因素: Medium

分数: 5.2

CVSS v2

风险因素: Low

基本分数: 3.6

时间分数: 2.7

矢量: AV:L/AC:L/Au:N/C:P/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.1

时间分数: 6.2

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:drupal:drupal

必需的 KB 项: installed_sw/Drupal, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2021/7/21

漏洞发布日期: 2021/7/21

参考资料信息

CVE: CVE-2021-32610

IAVA: 2021-A-0353-S