Oracle Linux 8:ghostscript (ELSA-2021-1852)

high Nessus 插件 ID 149960
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Oracle Linux 主机缺少一个或多个安全更新。

描述

远程 Oracle Linux 8 主机上安装的程序包受到 ELSA-2021-1852 公告中提及的多个漏洞的影响。

- 在 ghostscript-9.25 的 psi/igc.c 的 igc_reloc_struct_ptr() 中发现释放后使用。本地攻击者可提供特别构建的 PDF 文件造成拒绝服务。(CVE-2020-14373)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevcif.c 内的 cif_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16289)

- 在 Artifex Software GhostScript v9.50 中,devices/gdev3852.c 内的 jetp3852_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16290)

- 在 Artifex Software GhostScript v9.50 中,contrib/lips4/gdevlips.c 内的 GetNumWrongData() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16296)

- 在 Artifex Software GhostScript v9.50 中,contrib/gdevbjca.c 内的 FloydSteinbergDitheringC() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16297)

- 在 Artifex Software GhostScript v9.50 中,contrib/japanese/gdevmjc.c 内的 mj_color_correct() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16298)

- 在 Artifex Software GhostScript v9.50 中,base/gxicolor.c 文件内的 image_render_color_thresh() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 eps 文件提升权限。此缺陷已在 v9.51 中修复。(CVE-2020-16304)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevtsep.c 内存在空指针取消引用漏洞,远程攻击者可借此通过特别构建的 PostScript 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16306)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevdm24.c 内的 dot24_print_page() 存在除以零漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16310)

- 在 Artifex Software GhostScript v9.50 中,contrib/lips4/gdevlprn.c 内的 lprn_is_black() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16287)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevpjet.c 内的 pj_common_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16288)

- 在 Artifex Software GhostScript v9.50 中,contrib/gdevdj9.c 内存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16291)

- 在 Artifex Software GhostScript v9.50 中,contrib/japanese/gdevmjc.c 内的 mj_raster_cmd() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16292)

- 在 Artifex Software GhostScript v9.50 中,base/gxblend.c 内的 compose_group_nonknockout_nonblend_isolated_allmask_common() 存在空指针取消引用漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16293)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevepsc.c 内的 epsc_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16294)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevclj.c 内的 clj_media_size() 存在空指针取消引用漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16295)

- 在 Artifex Software GhostScript v9.50 中,contrib/japanese/gdev10v.c 内的 bj10v_print_page() 存在除以零漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16299)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevtfnx.c 内的 tiff12_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16300)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevokii.c 内的 okiibm_print_page1() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16301)

- 在 Artifex Software GhostScript v9.50 中,devices/gdev3852.c 文件内的 jetp3852_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件提升权限。此缺陷已在 v9.51 中修复。(CVE-2020-16302)

- 在 Artifex Software GhostScript v9.50 中,devices/vector/gdevxps.c 文件内的 xps_finish_image_path() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件提升权限。此缺陷已在 v9.51 中修复。(CVE-2020-16303)

- 在 Artifex Software GhostScript v9.50 中,contrib/japanese/gdev10v.c 内的 pcx_write_rle() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16305)

- 在 Artifex Software GhostScript v9.50 中,devices/vector/gdevtxtw.c 和 psi/zbfont.c 内存在空指针取消引用漏洞,远程攻击者可借此通过特别构建的 PostScript 文件造成拒绝服务。
此缺陷已在 v9.51 中修复。(CVE-2020-16307)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevcdj.c 内的 p_print_image() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16308)

- 在 Artifex Software GhostScript v9.50 中,devices/gdevlxm.c 内的 lxm5700m_print_page() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 eps 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-16309)

- 在 Artifex Software GhostScript v9.50 中,contrib/lips4/gdevlips.c 内的 GetNumSameData() 存在缓冲区溢出漏洞,远程攻击者可借此通过特别构建的 PDF 文件造成拒绝服务。此缺陷已在 v9.51 中修复。(CVE-2020-17538)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

更新受影响的程序包。

另见

https://linux.oracle.com/errata/ELSA-2021-1852.html

插件详情

严重性: High

ID: 149960

文件名: oraclelinux_ELSA-2021-1852.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/5/26

最近更新时间: 2021/5/26

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2020-16303

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 6.8

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:ghostscript, p-cpe:/a:oracle:linux:ghostscript-doc, p-cpe:/a:oracle:linux:ghostscript-tools-dvipdf, p-cpe:/a:oracle:linux:ghostscript-tools-fonts, p-cpe:/a:oracle:linux:ghostscript-tools-printing, p-cpe:/a:oracle:linux:ghostscript-x11, p-cpe:/a:oracle:linux:libgs, p-cpe:/a:oracle:linux:libgs-devel

必需的 KB 项: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

易利用性: No known exploits are available

补丁发布日期: 2021/5/25

漏洞发布日期: 2020/8/13

参考资料信息

CVE: CVE-2020-14373, CVE-2020-16287, CVE-2020-16288, CVE-2020-16289, CVE-2020-16290, CVE-2020-16291, CVE-2020-16292, CVE-2020-16293, CVE-2020-16294, CVE-2020-16295, CVE-2020-16296, CVE-2020-16297, CVE-2020-16298, CVE-2020-16299, CVE-2020-16300, CVE-2020-16301, CVE-2020-16302, CVE-2020-16303, CVE-2020-16304, CVE-2020-16305, CVE-2020-16306, CVE-2020-16307, CVE-2020-16308, CVE-2020-16309, CVE-2020-16310, CVE-2020-17538