Amazon Linux 2:python-pip (ALAS-2021-1639)

high Nessus 插件 ID 149875
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Amazon Linux 2 主机缺少安全更新。

描述

因此,该应用程序受到 ALAS2-2021-1639 公告中提及的漏洞的影响。

- Python 版 pip 程序包 19.2 之前版本在安装命令中指定 URL 时允许目录遍历,因为 Content-Disposition 标头在文件名中可以有 ../,这一点已由覆盖 /root/.ssh/authorized_keys 文件证实。这发生于 _download_http_url in _internal/download.py。
(CVE-2019-20916)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

运行 'yum update python-pip' 以更新系统。

另见

https://alas.aws.amazon.com/AL2/ALAS-2021-1639.html

https://access.redhat.com/security/cve/CVE-2019-20916

插件详情

严重性: High

ID: 149875

文件名: al2_ALAS-2021-1639.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/5/24

最近更新时间: 2021/5/24

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2019-20916

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:python-pip-wheel, p-cpe:/a:amazon:linux:python2-pip, p-cpe:/a:amazon:linux:python3-pip, cpe:/o:amazon:linux:2

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2021/5/20

漏洞发布日期: 2020/9/3

参考资料信息

CVE: CVE-2019-20916

ALAS: 2021-1639