Amazon Linux AMI:ruby24 (ALAS-2021-1501)

high Nessus 插件 ID 149791
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Amazon Linux AMI 主机缺少安全更新。

描述

远程主机上安装的 ruby24 版本低于 2.4.10-2.14 版 。因此,该应用程序受到 ALAS-2021-1501 公告中提及的漏洞的影响。

- Ruby 2.6.7 之前的 3.2.5、2.7.3 之前的 2.7.x 和 3.0.1 之前的 3.x 之前的 REXML gem 未能妥善解决 XML 循环问题。解析和序列化之后可能产生一个错误的文档。(CVE-2021-28965)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

运行 'yum update ruby24' 以更新系统。

另见

https://alas.aws.amazon.com/ALAS-2021-1501.html

https://access.redhat.com/security/cve/CVE-2021-28965

插件详情

严重性: High

ID: 149791

文件名: ala_ALAS-2021-1501.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/5/20

最近更新时间: 2021/5/20

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2021-28965

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:ruby24, p-cpe:/a:amazon:linux:ruby24-debuginfo, p-cpe:/a:amazon:linux:ruby24-devel, p-cpe:/a:amazon:linux:ruby24-doc, p-cpe:/a:amazon:linux:ruby24-irb, p-cpe:/a:amazon:linux:ruby24-libs, p-cpe:/a:amazon:linux:rubygem24-bigdecimal, p-cpe:/a:amazon:linux:rubygem24-did_you_mean, p-cpe:/a:amazon:linux:rubygem24-io-console, p-cpe:/a:amazon:linux:rubygem24-json, p-cpe:/a:amazon:linux:rubygem24-minitest5, p-cpe:/a:amazon:linux:rubygem24-net-telnet, p-cpe:/a:amazon:linux:rubygem24-power_assert, p-cpe:/a:amazon:linux:rubygem24-psych, p-cpe:/a:amazon:linux:rubygem24-rdoc, p-cpe:/a:amazon:linux:rubygem24-test-unit, p-cpe:/a:amazon:linux:rubygem24-xmlrpc, p-cpe:/a:amazon:linux:rubygems24, p-cpe:/a:amazon:linux:rubygems24-devel, cpe:/o:amazon:linux

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2021/5/14

漏洞发布日期: 2021/4/21

参考资料信息

CVE: CVE-2021-28965

ALAS: 2021-1501