Pivotal RabbitMQ 3.8.x < 3.8.16 DoS

high Nessus 插件 ID 149704
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 Web 应用程序受到拒绝服务漏洞影响。

描述

Pivotal RabbitMQ 3.8.x 的 3.8.16 之前版本受到拒绝服务 (DoS) 漏洞的影响,这是因为输入验证不当所致。远程攻击者可利用此问题,通过发送恶意 AMQP 消息造成服务器崩溃。

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级版本到 Pivotal RabbitMQ 3.8.16 或更高版本。

另见

https://tanzu.vmware.com/security/cve-2021-22116

https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.8.15

https://github.com/rabbitmq/rabbitmq-server/releases/tag/v3.8.16

插件详情

严重性: High

ID: 149704

文件名: rabbitmq_3_8_16.nasl

版本: 1.5

类型: local

代理: unix

系列: Misc.

发布时间: 2021/5/19

最近更新时间: 2021/7/30

依存关系: rabbitmq_server_nix_installed.nbin

风险信息

CVSS 分数来源: CVE-2021-22116

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:pivotal_software:rabbitmq

必需的 KB 项: installed_sw/RabbitMQ

易利用性: No known exploits are available

补丁发布日期: 2021/5/10

漏洞发布日期: 2021/5/10

参考资料信息

CVE: CVE-2021-22116

IAVB: 2021-B-0029-S