PHP 7.4.x < 7.4.18 / 8.x < 8.0.5 整数溢出

high Nessus 插件 ID 149348
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 版本受到整数溢出漏洞的影响。

描述

远程主机上安装的 PHP 版本为低于 7.4.18 的 7.4.x 或低于 8.0.5 的 8.x。因此,该应用程序会受到 pnctl_exec() 中整数溢出情况的影响。攻击者可利用此问题,造成拒绝服务 (DoS) 情况或执行任意代码。

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本

解决方案

升级到 PHP 7.4.18、8.0.5 或更高版本。

另见

https://www.php.net/ChangeLog-7.php#7.4.18

https://www.php.net/ChangeLog-8.php#8.0.5

插件详情

严重性: High

ID: 149348

文件名: php_8_0_5.nasl

版本: 1.2

类型: remote

系列: CGI abuses

发布时间: 2021/5/7

最近更新时间: 2021/6/3

依存关系: php_version.nasl

风险信息

CVSS 分数来源: manual

CVSS 分数理由: Score based on analysis of vendor advisory.

CVSS v2

风险因素: Medium

基本分数: 6.8

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

风险因素: High

基本分数: 8.3

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

补丁发布日期: 2021/4/29

漏洞发布日期: 2021/4/29

参考资料信息

IAVA: 2021-A-0210-S